Bug 1206869 - Microsoft Surface Pro 3 touchpad causes gui to crash
Summary: Microsoft Surface Pro 3 touchpad causes gui to crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 22
Hardware: x86_64
OS: Windows
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-29 04:39 UTC by jd528927
Modified: 2015-04-28 13:08 UTC (History)
3 users (show)

Fixed In Version: libinput-0.14.1-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-28 13:08:47 UTC


Attachments (Terms of Use)
Xorg.log (26.83 KB, text/plain)
2015-04-24 04:37 UTC, Peter Hutterer
no flags Details
evemu recording (20.06 KB, text/plain)
2015-04-24 04:37 UTC, Peter Hutterer
no flags Details

Description jd528927 2015-03-29 04:39:53 UTC
Description of problem:Touching the touchpad on the surface pro 3 keyboard causes gnome to crash


Version-Release number of selected component (if applicable):F22


How reproducible:touch keypad anytime


Steps to Reproduce:
1.touch keypad
2.
3.

Actual results:crash


Expected results:operate mouse


Additional info:from systemd log 
Device dev-disk-by\x2dpartlabel-Basic\x5cx20data\x5cx20partition.device appeared twice with different sysfs paths /sys/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda4 and /sys/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda1i8042: 

Can't read CTR while initializing i8042

Comment 1 jd528927 2015-03-29 04:52:22 UTC
crash caused by touching touchpad, not keypad.

Comment 2 Peter Hutterer 2015-04-20 04:48:06 UTC
can you provide a crash log and the output of evemu-record when a crash happens?

Comment 3 Peter Hutterer 2015-04-24 04:37:19 UTC
Created attachment 1018293 [details]
Xorg.log

xorg.log from reporter (accidentally sent via email)

Comment 4 Peter Hutterer 2015-04-24 04:37:51 UTC
Created attachment 1018294 [details]
evemu recording

evemu recording from reporter (accidentally sent by email)

Comment 5 Fedora Update System 2015-04-24 06:01:21 UTC
libinput-0.14.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libinput-0.14.1-2.fc22

Comment 6 Fedora Update System 2015-04-26 12:48:15 UTC
Package libinput-0.14.1-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libinput-0.14.1-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6874/libinput-0.14.1-2.fc22
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-04-28 13:08:47 UTC
libinput-0.14.1-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.