Bug 1206931 - cheese there was an error playing video from webcam
Summary: cheese there was an error playing video from webcam
Keywords:
Status: CLOSED DUPLICATE of bug 1194992
Alias: None
Product: Fedora
Classification: Fedora
Component: cheese
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-29 17:57 UTC by Carlos (Morel-Riquelme)
Modified: 2015-05-19 13:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-19 13:27:29 UTC


Attachments (Terms of Use)

Description Carlos (Morel-Riquelme) 2015-03-29 17:57:59 UTC
Description of problem:
some time cheese launch the "there was an error playing video from webcam" error

Version-Release number of selected component (if applicable):

[iddnna@localhost ~]$ rpm -qa |grep -i cheese
cheese-libs-3.16.0-1.fc22.x86_64
cheese-3.16.0-1.fc22.x86_64
[iddnna@localhost ~]$ 

Steps to Reproduce:
1. Press "take picture" button 
2. Cheese launch the error


Additional info:


Graphic Card information

[root@localhost RPM]# lspci -v -s `lspci | awk '/VGA/{print $1}'`
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Acer Incorporated [ALI] Device 0622
	Flags: bus master, fast devsel, latency 0, IRQ 25
	Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at b0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 4000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [a4] PCI Advanced Features
	Kernel driver in use: i915
	Kernel modules: i915

------------------------------------------------------------------------------

Dmesg information

[iddnna@localhost ~]$ dmesg
[   10.842292] uvcvideo: Found UVC 1.00 device WebCam (04f2:b209)
[   10.847457] input: WebCam as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.0/input/input17
[   10.849906] usbcore: registered new interface driver uvcvideo
[   10.851967] USB Video Class driver (1.1.1)

[iddnna@localhost ~]$

[root@localhost RPM]#

-----------------------------------------------------------------------------

Here the screencast

https://iddnna.fedorapeople.org/webm/Screencast%20from%2003-29-2015%2010:55:50%20AM.webm

Comment 1 Carlos (Morel-Riquelme) 2015-03-29 21:13:09 UTC
Sorry i forget put the output. here is

[iddnna@localhost ~]$ /usr/bin/cheese
libv4l2: error setting pixformat: Device or resource busy

(cheese:6115): cheese-WARNING **: Device '/dev/video0' is busy: gstv4l2object.c(2838): gst_v4l2_object_set_format (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin35/GstV4l2Src:video_source:
Call to S_FMT failed for YU12 @ 640x480: Device or resource busy

[iddnna@localhost ~]$

Comment 2 Wim Taymans 2015-05-19 13:27:29 UTC

*** This bug has been marked as a duplicate of bug 1194992 ***


Note You need to log in before you can comment on or make changes to this bug.