Bug 1207022 - Inconsistent mouse/click behaviour in UI
Summary: Inconsistent mouse/click behaviour in UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-30 05:20 UTC by David O'Brien
Modified: 2019-09-25 21:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:50:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14118 None None None 2016-04-22 15:46:00 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description David O'Brien 2015-03-30 05:20:26 UTC
Description of problem:

If you go to Content > RH repositories and want to select a product, you can click either the right-arrow or the product name to expand it. To expand a Repository Set, you actually have to click the little black right-arrow.

Version-Release number of selected component (if applicable):
6.1.0

How reproducible:

Always

Steps to Reproduce:
1. Navigate to Content > RH Repositories
2. On the RPMs tab, click any product to expand it
3. For any repository set, need to click the right-arrow

Actual results:

Clicking the repository set name does nothing.

Expected results:

It would be a far better UX if you click the name instead of searching for the little right-arrow to click it.

Additional info:

Comment 1 RHEL Program Management 2015-03-30 05:23:07 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 David O'Brien 2015-03-30 05:53:01 UTC
Let me update this:

It seems the repository set *does* expand, but the mouse cursor doesn't change when you hover the repository set name. I clicked it by accident and it behaves as expected.

Comment 4 Brad Buckingham 2016-03-09 12:35:06 UTC
Created redmine issue http://projects.theforeman.org/issues/14118 from this bug

Comment 5 Brad Buckingham 2016-03-09 12:38:02 UTC
Upstream katello pr: https://github.com/Katello/katello/pull/5861

Comment 6 Bryan Kearney 2016-03-09 21:09:16 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14118 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|3bb4f065dda8bf37077461ddaf795c32930bc56d.

Comment 8 jcallaha 2016-06-17 19:27:33 UTC
Verified in Satellite 6.2 Beta Snap 15.2

UI behavior is acting appropriately in the Red Hat Repositories page.

Comment 10 errata-xmlrpc 2016-07-27 08:50:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.