Bug 1207079 - Shortcut for ksnapshot don't work with kde5 (plasma5)
Summary: Shortcut for ksnapshot don't work with kde5 (plasma5)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-workspace
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F22BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-03-30 08:11 UTC by dominique
Modified: 2015-04-17 02:30 UTC (History)
10 users (show)

Fixed In Version: plasma-workspace-5.2.2-5.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-17 02:30:01 UTC
Type: Bug


Attachments (Terms of Use)

Description dominique 2015-03-30 08:11:12 UTC
With F21 and kde4, I use shortcut (FN + Print-screen) for launch ksnapshot.
My laptop is Toshiba Satelitte L770/775.

With F22 and KDE 5, this shortcut don't work.

With Xfce ans F22, that work (that launch the Xfce's print-screen).

With xev, I can see that shortcut is active but return false :

KeyPress event, serial 40, synthetic NO, window 0x5000001,
    root 0x284, subw 0x0, time 4250761, (471,440), root:(1111,469),
    state 0x10, keycode 107 (keysym 0xff61, Print), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 40, synthetic NO, window 0x5000001,
    root 0x284, subw 0x0, time 4250868, (471,440), root:(1111,469),
    state 0x10, keycode 107 (keysym 0xff61, Print), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Can you solve this bug ?

Comment 1 Rex Dieter 2015-03-30 13:30:12 UTC
Confirmed, Prnt Scrn shortcut stopped working at some point.  I remember it working for me on f22-alpha initial install, so I suspect it broke along the way since then.

Comment 2 Kevin Kofler 2015-03-30 18:40:50 UTC
Could this be related to, or even caused by, libinput?

Comment 3 Rex Dieter 2015-03-30 18:55:48 UTC
Good question, but I think not, I uninstalled xorg-x11-drv-libinput and removed my ~/.config/kglobalshortcutsrc, restarted, no difference.

Comment 4 Lukáš Tinkl 2015-03-30 21:59:04 UTC
This is related to khotkeys.

Comment 5 dominique 2015-03-31 04:20:53 UTC
(In reply to Lukáš Tinkl from comment #4)
> This is related to khotkeys.

Thank Lukas, I have not khotkeys 's package installed.

I install khotkeys-5.2.1.2 and after reboot my shortcut work well.

I don't know why this package is not installed.

Thank again.

Comment 6 Rex Dieter 2015-03-31 15:03:20 UTC
%changelog
* Tue Mar 31 2015 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-4
- Requires: khotkeys (#1207079)

Comment 7 Fedora Update System 2015-04-06 11:56:45 UTC
plasma-workspace-5.2.2-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-5161/plasma-workspace-5.2.2-5.fc22

Comment 8 Fedora Blocker Bugs Application 2015-04-06 11:59:00 UTC
Proposed as a Freeze Exception for 22-beta by Fedora user rdieter using the blocker tracking app because:

 A missing runtime dependency (on khotkeys) means shortcuts (including 'print screen') do not function.

Comment 9 Adam Williamson 2015-04-06 17:28:02 UTC
Discussed at 2015-04-06 freeze exception review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-06/f22-blocker-review.2015-04-06-16.00.log.txt . Accepted as an FE: fix seems very low-risk and this obviously has a visible impact on using the KDE lives.

Comment 10 satellitgo 2015-04-14 22:45:58 UTC
works for me in f22 KDE RC2 installed to hd

Comment 11 Fedora Update System 2015-04-17 02:30:01 UTC
plasma-workspace-5.2.2-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.