Bug 1207132 - Snapshot:snapshot list should display in sorted order based on timestamp
Summary: Snapshot:snapshot list should display in sorted order based on timestamp
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-30 10:02 UTC by Mohammed Rafi KC
Modified: 2015-05-14 17:46 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:29:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-03-30 10:02:21 UTC
Description of problem:

gluster snapshot list shows the snapshot names in unsorted order.

Version-Release number of selected component (if applicable):

mainline

How reproducible:

1/1

Steps to Reproduce:
1.create three or more snapshots
2.gluster snapshot list
3.

Actual results:

result in unsorted order

Expected results:

result should be in sorted order

Additional info:

Comment 1 Anand Avati 2015-03-30 10:03:17 UTC
REVIEW: http://review.gluster.org/10046 (glusterd:Change glusterd_list_add_order to add entry in ascending order) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-03-30 10:05:32 UTC
REVIEW: http://review.gluster.org/10046 (glusterd:Change glusterd_list_add_order to add entry in ascending order) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Anand Avati 2015-03-30 11:13:03 UTC
REVIEW: http://review.gluster.org/10046 (glusterd:Change glusterd_list_add_order to add entry in ascending order) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Anand Avati 2015-04-06 06:38:55 UTC
REVIEW: http://review.gluster.org/10046 (glusterd:Change glusterd_list_add_order to add entry in ascending order) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 5 Anand Avati 2015-04-08 09:20:19 UTC
COMMIT: http://review.gluster.org/10046 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 6bf07eb642cb82e0de5d96511b6fd13a8838d11d
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Mar 30 15:24:00 2015 +0530

    glusterd:Change glusterd_list_add_order to add entry in ascending order
    
    Change-Id: I0f82b1b5ad37e06135e9af33a4b5342ddde3ca94
    BUG: 1207132
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/10046
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 6 Niels de Vos 2015-05-14 17:29:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:38:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:46:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.