Bug 120721 - raw in mime type, cause driver epson LX-300 don't print in gnome
raw in mime type, cause driver epson LX-300 don't print in gnome
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 09:48 EDT by Lewi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 08:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lewi 2004-04-13 09:48:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; ICHTUS; Linux i686; en-US; rv:1.6)
Gecko/20040225 Mozilla Firefox/0.8

Description of problem:
problem in cups when /etc/cups/mime* edited to enable raw printing
(default redhat-config-printer just disable this when running
redhat-config-printer after edit this file)
driver Epson LX-300, or maybe all driver for dotmatrix printer
don't print in gnome, but with command line and kde file can be printed

Version-Release number of selected component (if applicable):
cups-1.1.19-13

How reproducible:
Always

Steps to Reproduce:
1.edit /etc/cups/mime.* to enable raw printing
2.add driver with redhat-config-printer LX-300
3.edit file above again, because redhat-config-printer disable again
4.print from gnome apps
    

Actual Results:  paper just rolling without print

Expected Results:  print well

Additional info:
Comment 1 Tim Waugh 2004-04-14 08:50:27 EDT
Why do you want raw printing?  How are you trying to print?  Why don't
you set the queue to be raw from the redhat-config-printer tool
instead of editing the file?

Need more information..
Comment 2 Lewi 2004-04-19 22:20:35 EDT
I think that's because, I saw when using normal queue, in samba
log says that need raw printing, to get windows printing to linux
printer, beside that windows won't print

I will try this, I dunno before
Comment 3 Tim Waugh 2004-05-06 08:02:51 EDT
Then add 'cups options = raw' to the smb.conf file.  The mime.convs
file should not need editing.
Comment 4 Aleksandar Milivojevic 2005-04-25 11:18:46 EDT
Hm, I have some problems with printing directly from Windows XP to Cups (XP can
print to Cups directly, no need to install/configure/use Samba).  Depending on
the printer driver used on Windows XP, the content type of the print job
changes.  This worked perfectly for my old (non-PS) Brother printer.  However
for my Samsung ML-1740 printer, XP uses application/octet-stream.  It seems that
for this, I need to have raw printing enabled in mime.* files.  However, I don't
want the queue to be forced to raw (wich I guess setting the raw option on the
queue in system-config-printer would do).  I just want support for
application/octet-stream.

Anyhow, after I configure the printer, Cups complains (in log files) that I need
to enable raw printing.  If I uncomment the application/octet-stream lines in
mime.* files, and restart cups, Cups does not complain anymore, however nothing
is sent to the printer either!?  Cups simply eats the job with no error message.
 I even attempted running cups with debug logging, but nothing usable was logged.

For now, as a temporary workaround, I told Windows XP to use Apple LaserWriter
Color 12/600 device drivers (since that printer seems to have similar margins
and printable area to my Samsung printer, which I found out by trial and error).
 Those generate postcript (with appropriate content-type).  However, I'd really
like to be able to use Samsung driver, since it has controls for features as
per-job toner economy settings (and some other printer features) that I don't
have access to using PS drivers.

Note You need to log in before you can comment on or make changes to this bug.