Bug 120727 - tests fail for Crypt::Random on Fedora 1 but not on Redhat 9
tests fail for Crypt::Random on Fedora 1 but not on Redhat 9
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 11:48 EDT by Peter teStrake
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-06 15:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter teStrake 2004-04-13 11:48:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
I get segment faults when running Crypt::Random tests.  The same
applies for Crypt::Primes.  

Version-Release number of selected component (if applicable):
Crypt::Random 1.13

How reproducible:
Always

Steps to Reproduce:
I am installing in order
1. pari-2.1.5 (http://pari.math.u-bordeaux.fr/download/pari-2.1.5.tgz)

2. Math::Pari
(http://search.cpan.org/CPAN/authors/id/I/IL/ILYAZ/modules/Math-Pari-2.010501.tar.gz)

3. Class::Loader
(http://search.cpan.org/CPAN/authors/id/V/VI/VIPUL/Class-Loader-2.02.tar.gz)


Actual Results:  When I try and install Crypt::Random, one of the
tests fail.
t/pari_misfeature....dubious
        Test returned status 0 (wstat 11, 0xb)
DIED. FAILED test 1

when I look closer at this error I see its a Segment Fault.
[root@localhost Crypt-Random-1.13]# perl -Mblib t/pari_misfeature.t
1..1
Segmentation fault

if I strace this problem I get
close(3)                                = 0
stat64("/dev/urandom", {st_mode=S_IFCHR|0644, st_rdev=makedev(1, 9),
...}) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

The problem seems to be caused after the return statement in the "new"
function in lib/Crypt/Random/Provider/File.pm.

Additional info:


This appears to be fedora 1.0 specific, the same process installation
works fine on redhat 9.  Additionaly, I have run yum and installed all
the updates, but this did not resolve the problem.

What should I do now to isolate this problem further.
Comment 1 Peter teStrake 2004-06-06 15:08:15 EDT
This is resolved with Crypt::Random 1.22

Note You need to log in before you can comment on or make changes to this bug.