Bug 1207343 - SQL query failed during tiering rebalancer and write/read frequency thresolds not work
Summary: SQL query failed during tiering rebalancer and write/read frequency thresolds...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: pre-release
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Lambright
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1260923
TreeView+ depends on / blocked
 
Reported: 2015-03-30 18:02 UTC by Joseph Elwin Fernandes
Modified: 2016-06-20 00:01 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:29:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Joseph Elwin Fernandes 2015-03-30 18:02:45 UTC
Description of problem:
SQL query failed during tiering rebalancer and write/read frequency thresolds not work

Version-Release number of selected component (if applicable):


How reproducible:

gluster volume <volumename > tier rebalancer

[2015-03-27 17:25:42.078335] E [gfdb_sqlite3.c:864:gf_sqlite3_find_recently_changed_files_freq] 0-sqlite3: Failed preparing statment select GF_FILE_TB.GF_ID, (select group_concat( GF_PID || ',' || FNAME || ',' || FPATH || ',' || W_DEL_FLAG ||',' || LINK_UPDATE , '::') from GF_FLINK_TB where GF_FILE_TB.GF_ID = GF_FLINK_TB.GF_ID)  from GF_FILE_TB where ( ((GF_FILE_TB.W_SEC * 1000000 + GF_FILE_TB.W_MSEC) >= ? ) AND  (GF_FILE_TB.WRITE_FREQ_CNTR > = ? ) ) OR ( ((GF_FILE_TB.W_READ_SEC * 1000000 + GF_FILE_TB.W_READ_MSEC) <= ?) AND  (GF_FILE_TB.READ_FREQ_CNTR > = ? ) ) : near "=": syntax error

gluster volume set cluster.write-freq-threshold 0;
failed!

gluster volume set cluster.read-freq-threshold 0;
failed!
Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-03-30 18:05:54 UTC
REVIEW: http://review.gluster.org/10050 (Gfdb Query Fix and Volume option fix) posted (#2) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 2 Anand Avati 2015-03-30 20:39:25 UTC
COMMIT: http://review.gluster.org/10050 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 3feaf1648528ff39e23748ac9004a77595460c9d
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Mon Mar 30 17:23:29 2015 +0530

    Gfdb Query Fix and Volume option fix
    
    1) Query fix in find_changed_with_freq()
    2) Volume option typo fix for write_freq_threshold
       and read_freq_threshold
    
    Change-Id: I38e154818178aab412b2d7b2914cd29acef66ffb
    BUG: 1207343
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/10050
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:29:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:35:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:38:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:46:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.