Bug 1207478 - selinux denying backlight handling when Xorg running as user
Summary: selinux denying backlight handling when Xorg running as user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1209227 1209259 1210735 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-31 01:51 UTC by Kevin Fenzi
Modified: 2015-04-25 20:23 UTC (History)
14 users (show)

Fixed In Version: selinux-policy-3.13.1-122.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 19:28:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Fenzi 2015-03-31 01:51:26 UTC
After gdm changed to set: 

XORG_RUN_AS_USER_OK

Xorg runs as my user and works fine except for the backlight handling. 

  |       `-gdm-x-session,1560 --run-script startxfce4
  |           |-{gmain},1563
  |           |-Xorg,1564 vt3 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -backg
round none -noreset -keeptty ...
  |           |   |-{Xorg},1571
  |           |   `-xf86-video-inte,1577 intel_backlight

type=USER_AVC msg=audit(1427766120.077:2089): pid=921 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=signal interface=org.freedesktop.PolicyKit1.Authority member=Changed dest=org.freedesktop.DBus spid=1455 tpid=1577 scontext=system_u:system_r:policykit_t:s0 tcontext=unconfined_u:unconfined_r:xserver_t:s0-s0:c0.c1023 tclass=dbus  exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'

root      1577  0.0  0.0   4216   720 tty3     S+   19:41   0:00 /usr/libexec/xf86-video-intel-backlight-helper intel_backlight

Happy to gather more info, etc

Comment 1 Tim Waugh 2015-04-02 14:40:10 UTC
Now seen in Fedora 22 with:

gdm-3.16.0.1-2.fc22.x86_64
xorg-x11-server-Xorg-1.17.1-7.fc22.x86_64
xorg-x11-drv-intel-2.99.917-6.20150211.fc22.x86_64
selinux-policy-3.13.1-119.fc22.noarch

Comment 2 Lukas Vrabec 2015-04-07 08:37:55 UTC
commit c5e49dcca670b534ae18c2278eee2075a40ee794
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Tue Apr 7 10:35:29 2015 +0200

    Allow polkit to dbus chat with xserver. (1207478)

Comment 3 Julius B. 2015-04-14 10:53:51 UTC
I can confirm that selinux-policy-3.13.1-121.fc22 fixes this bug. Thank you for your work, Lukas!

Comment 4 Paul W. Frields 2015-04-16 15:56:22 UTC
*** Bug 1209259 has been marked as a duplicate of this bug. ***

Comment 5 Paul W. Frields 2015-04-16 15:56:25 UTC
*** Bug 1210735 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2015-04-16 20:17:27 UTC
selinux-policy-3.13.1-122.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-122.fc22

Comment 7 Fedora Update System 2015-04-17 18:36:30 UTC
Package selinux-policy-3.13.1-122.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.13.1-122.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6236/selinux-policy-3.13.1-122.fc22
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-04-21 19:28:46 UTC
selinux-policy-3.13.1-122.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Vít Ondruch 2015-04-25 20:23:48 UTC
*** Bug 1209227 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.