Bug 1207485 - Create Guarani (GN) translation team
Summary: Create Guarani (GN) translation team
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora Localization
Classification: Fedora
Component: l10n-requests
Version: unspecified
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: noriko
QA Contact: A S Alam
URL:
Whiteboard:
Depends On:
Blocks: 1546484
TreeView+ depends on / blocked
 
Reported: 2015-03-31 02:46 UTC by Esteban RD
Modified: 2018-02-20 04:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-20 04:29:48 UTC


Attachments (Terms of Use)

Description Esteban RD 2015-03-31 02:46:57 UTC
Description of problem:
I'm translator of Fedora Linux in Spanish and Portuguese Brazil. There is now one more person who wants to translate Fedora in Guaraní (GN) and we are going to create Guaraní translation team.

Actual results:
Actually I already member of 'cvsl10n' 'ambassadors' 'fedora-py' 'fedora-br' group as user.

Expected results:
I just need to be registered as maintainer of Guaraní language and be registered as group sponsor. 

Also please create bugzilla component for Guaraní (GN) language in owners.list (according to http://fedoraproject.org/wiki/L10N/FAQ#bugzilla-team)
Patch attached


Additional info:
Data according to http://fedoraproject.org/wiki/L10N/FAQ#new-team

We have several open source projects, nosso em native language; Guarani can quote Mozilla http://www.mozillabolivia.org/firefox-guarani/


Language: Guaraní (http://en.wikipedia.org/wiki/Guarani_language)
My name: Esteban Ruiz Diaz Baez
FAS account: stbnruiz001
E-mail: stbnruiz001@gmail.com
Maillist: https://admin.fedoraproject.org/mailman/listinfo/trans-gn
Bugzilla account: stbnruiz001@gmail.com

Comment 1 Piotr Drąg 2015-04-02 16:02:52 UTC
I've made you a sponsor, added the new team to wiki and the Bugzilla component with you as the initial owner and QA contact, and the mailing list as the default CC. Sean is taking care of adding Guarani to Zanata.

https://fedoraproject.org/w/index.php?title=L10N_Teams&diff=408838&oldid=406762

https://git.fedorahosted.org/cgit/l10n/owners.git/commit/?id=1b808c86f8efacd6796dbfde7a86e89e7e707e83

Comment 2 Esteban RD 2015-04-07 17:32:10 UTC
I need to do or report any more information from me? Just to know
Regard's!

Esteban

Comment 3 Piotr Drąg 2015-04-07 17:39:23 UTC
I don't really know. Let's ask Sean!

Comment 4 Sean Flanigan 2015-04-08 00:24:08 UTC
We still need to get clarification and confirmation on the plural rules: https://lists.fedoraproject.org/pipermail/trans/2015-April/011960.html
https://lists.fedoraproject.org/pipermail/trans/2015-March/011952.html

Then put in a bugzilla and we'll make sure Guarani support gets into a Zanata release: https://bugzilla.redhat.com/enter_bug.cgi?product=Zanata

Comment 5 Esteban RD 2015-04-08 17:13:34 UTC
Sean, It would be like this:


English: Guarani
Guarani: Guaraní

"Plural-Forms: nplurals=2; plural=(n != 1);\n".a

Comment 6 Esteban RD 2015-04-08 20:45:36 UTC
http://mozilla.locamotion.org/gn_PY/

Comment 7 Sean Flanigan 2015-04-09 03:14:50 UTC
(In reply to Esteban RD from comment #6)
> http://mozilla.locamotion.org/gn_PY/

Hi Esteban, I can't see anything on that page to confirm which are the correct the plural rules.

Comment 8 Domingo Becker 2015-04-09 12:03:43 UTC
(In reply to Sean Flanigan from comment #7)
> (In reply to Esteban RD from comment #6)
> > http://mozilla.locamotion.org/gn_PY/
> 
> Hi Esteban, I can't see anything on that page to confirm which are the
> correct the plural rules.

According to what a person who speaks Guarani (Esteban) told me, the rule is the one in #c5.

A reference could be the following

http://www.proel.org/index.php?pagina=mundo/amerindia/tupian/guarani/guarani

where you may see there are two possibilities, singular and plural, the same as in Spanish.

https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_and_Plurals#Plural_rule_.231_.282_forms.29

Comment 9 Sean Flanigan 2015-04-10 00:21:10 UTC
Both suggested rules (n!=1 or n>1) have singular and plural.  (That is, the difference is the treatment of the zero case.)  

The problem is, the first plural information Esteban provided on the mailing list had the other rule (where n>1 is plural): https://lists.fedoraproject.org/pipermail/trans/2015-March/011957.html


I can't see any sign that Mozilla has settled on a rule for Guarani:

https://github.com/translate/mozilla-l10n/blob/master/gn_PY/toolkit/chrome/global/intl.properties.po#L82 (note the empty msgstr for pluralRule)

(That file is derived from https://github.com/mozilla/gecko-dev/blob/master/toolkit/locales/en-US/chrome/global/intl.properties which is where the msgid "1" came from.)


The same goes for Unicode.org (currently no entry for Guarani): http://www.unicode.org/cldr/charts/latest/supplemental/language_plural_rules.html


It's important to have confirmation on the plural rules before putting the Guarani rules into Zanata, because changing the rules will affect any existing translations.


(And this Transifex ticket was never closed, apparently due to lack of confirmed information: https://github.com/transifex/transifex/issues/181 .  Also note the use of the other plural rule. )

Comment 10 Esteban RD 2015-04-10 12:13:16 UTC
Sean understand the problem... with all this I see the lack of documented sources; It is the main point, all attempts to insert a plural rule was abandoned just because lack of commitment and dedication to research by my people (according to what you've shown me). 
For my part, I assure you I will not let this project die, and I tell Sean that the right is the rule discussed in C#5

Comment 11 Domingo Becker 2015-04-11 13:18:36 UTC
(In reply to Sean Flanigan from comment #9)
> Both suggested rules (n!=1 or n>1) have singular and plural.  (That is, the
> difference is the treatment of the zero case.)  
> 
> The problem is, the first plural information Esteban provided on the mailing
> list had the other rule (where n>1 is plural):
> https://lists.fedoraproject.org/pipermail/trans/2015-March/011957.html
> 
> 
> I can't see any sign that Mozilla has settled on a rule for Guarani:
> 
> https://github.com/translate/mozilla-l10n/blob/master/gn_PY/toolkit/chrome/
> global/intl.properties.po#L82 (note the empty msgstr for pluralRule)
> 
> (That file is derived from
> https://github.com/mozilla/gecko-dev/blob/master/toolkit/locales/en-US/
> chrome/global/intl.properties which is where the msgid "1" came from.)
> 

I see these two files and I interpret a different thing. 

The line 55 from the second link says "use the rule #1" from

https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_and_Plurals

That line is an assignment. 

pluralRule=1

Mozilla has settled a rule for Guarani in that file. No chance for confussion.

> 
> It's important to have confirmation on the plural rules before putting the
> Guarani rules into Zanata, because changing the rules will affect any
> existing translations.
> 

I understand your point.

I guess it should be the same used for Spanish, ie n!=1 or rule number 1 from mozilla's page.

In Spanish, for n=0 we use sometimes the plural form and some others the singular form. Either form will not affect the meaning.

What is Zanata actually using for Spanish?

Comment 12 Sean Flanigan 2015-04-13 00:30:01 UTC
(In reply to Domingo Becker from comment #11)
> (In reply to Sean Flanigan from comment #9)
> > Both suggested rules (n!=1 or n>1) have singular and plural.  (That is, the
> > difference is the treatment of the zero case.)  
> > 
> > The problem is, the first plural information Esteban provided on the mailing
> > list had the other rule (where n>1 is plural):
> > https://lists.fedoraproject.org/pipermail/trans/2015-March/011957.html
> > 
> > 
> > I can't see any sign that Mozilla has settled on a rule for Guarani:
> > 
> > https://github.com/translate/mozilla-l10n/blob/master/gn_PY/toolkit/chrome/
> > global/intl.properties.po#L82 (note the empty msgstr for pluralRule)
> > 
> > (That file is derived from
> > https://github.com/mozilla/gecko-dev/blob/master/toolkit/locales/en-US/
> > chrome/global/intl.properties which is where the msgid "1" came from.)
> > 
> 
> I see these two files and I interpret a different thing. 
> 
> The line 55 from the second link says "use the rule #1" from

Which link?  

Line 55 in the en-US file just says that *English* uses plural rule #1.
Line 55 in the gn_PY properties file is just part of a comment.

As I said, msgstr is empty in the gn_PY properties file, which means no value has been entered.  The msgid (1) was copied from the en_US file, like all the other msgids in the file.
 
> https://developer.mozilla.org/en-US/docs/Mozilla/Localization/
> Localization_and_Plurals
> 
> That line is an assignment. 
> 
> pluralRule=1
> 
> Mozilla has settled a rule for Guarani in that file. No chance for
> confussion.
>
> > 
> > It's important to have confirmation on the plural rules before putting the
> > Guarani rules into Zanata, because changing the rules will affect any
> > existing translations.
> > 
> 
> I understand your point.
> 
> I guess it should be the same used for Spanish, ie n!=1 or rule number 1
> from mozilla's page.
> 
> In Spanish, for n=0 we use sometimes the plural form and some others the
> singular form. Either form will not affect the meaning.
> 
> What is Zanata actually using for Spanish?

es=nplurals=2; plural=(n != 1)

Comment 13 Domingo Becker 2015-04-13 01:07:13 UTC
(In reply to Sean Flanigan from comment #12)
> (In reply to Domingo Becker from comment #11)
> > (In reply to Sean Flanigan from comment #9)
> > > Both suggested rules (n!=1 or n>1) have singular and plural.  (That is, the
> > > difference is the treatment of the zero case.)  
> > > 
> > > The problem is, the first plural information Esteban provided on the mailing
> > > list had the other rule (where n>1 is plural):
> > > https://lists.fedoraproject.org/pipermail/trans/2015-March/011957.html
> > > 
> > > 
> > > I can't see any sign that Mozilla has settled on a rule for Guarani:
> > > 
> > > https://github.com/translate/mozilla-l10n/blob/master/gn_PY/toolkit/chrome/
> > > global/intl.properties.po#L82 (note the empty msgstr for pluralRule)
> > > 
> > > (That file is derived from
> > > https://github.com/mozilla/gecko-dev/blob/maste r/toolkit/locales/en-US/
> > > chrome/global/intl.properties which is where the msgid "1" came from.)
> > > 
> > 
> > I see these two files and I interpret a different thing. 
> > 
> > The line 55 from the second link says "use the rule #1" from
> 
> Which link?  
> 

The last one.
Then, that file is only applied to en-US and its translation is applied to the target language. Am I right?

> Line 55 in the en-US file just says that *English* uses plural rule #1.
> Line 55 in the gn_PY properties file is just part of a comment.
> 
> As I said, msgstr is empty in the gn_PY properties file, which means no
> value has been entered.  The msgid (1) was copied from the en_US file, like
> all the other msgids in the file.
>  

I think I understand its meaning and usage now. Sorry.

Then it should have value of 1.

> > 
> > What is Zanata actually using for Spanish?
> 
> es=nplurals=2; plural=(n != 1)

It is the correct one.  And it is the value to use for Guarani.

Thank you, for your clarification.

Comment 14 Sean Flanigan 2015-04-13 02:26:38 UTC
(In reply to Domingo Becker from comment #13)
> (In reply to Sean Flanigan from comment #12)
> > (In reply to Domingo Becker from comment #11)

> > > 
> > > What is Zanata actually using for Spanish?
> > 
> > es=nplurals=2; plural=(n != 1)
> 
> It is the correct one.  And it is the value to use for Guarani.

Are you saying that because you speak Guarani and you can confirm that the plural rules are identical to Spanish ?
 
> Thank you, for your clarification.

Incidentally, I think I found another project which got stuck on confirmation for the plural rules: http://comments.gmane.org/gmane.linux.mageia.i18n/5979

Comment 15 Domingo Becker 2015-04-13 12:25:33 UTC
(In reply to Sean Flanigan from comment #14)
> (In reply to Domingo Becker from comment #13)
> > (In reply to Sean Flanigan from comment #12)
> > > (In reply to Domingo Becker from comment #11)
> 
> > > > 
> > > > What is Zanata actually using for Spanish?
> > > 
> > > es=nplurals=2; plural=(n != 1)
> > 
> > It is the correct one.  And it is the value to use for Guarani.
> 
> Are you saying that because you speak Guarani and you can confirm that the
> plural rules are identical to Spanish ?
>  

I don't speak Guarani. Esteban does, and I asked him about plural forms.

After his explanation, I see it's rule #1 from Mozilla's page.

> > Thank you, for your clarification.
> 
> Incidentally, I think I found another project which got stuck on
> confirmation for the plural rules:
> http://comments.gmane.org/gmane.linux.mageia.i18n/5979

Yes, I see. And it's not clear for me if Guarani is already in glibc.

The latest effort to add a language got stuck there.

Thanks.

Comment 16 Sean Flanigan 2015-04-15 02:42:57 UTC
We need independent confirmation, from another Guarani speaker, of the exact plural rules for Guarani.

Comment 17 noriko 2018-02-17 07:45:09 UTC
Hi, I just took over this component's assignee, so please allow me a question.
Has this bug been resolved? Or any help is needed? Let's roll the ball.

Comment 18 Piotr Drąg 2018-02-18 16:39:27 UTC
There is no Guaraní locale in glibc, which pretty much blocks any efforts to translate to that language. Someone invested in this should file a bug at https://sourceware.org/bugzilla/enter_bug.cgi?product=glibc (component “localedata”). Nothing we can do in Fedora right now, so we can close this (and re-open after a locale has been added to glibc and we have translators volunteering).


Note You need to log in before you can comment on or make changes to this bug.