Bug 120749 - rpm -i segmentation fault
rpm -i segmentation fault
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 14:11 EDT by Ronald Cole
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 20:21:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nessus libraries: build and install me first (420.30 KB, application/octet-stream)
2004-04-13 14:13 EDT, Ronald Cole
no flags Details
nasl: build and install me second (360.78 KB, application/octet-stream)
2004-04-13 14:14 EDT, Ronald Cole
no flags Details

  None (edit)
Description Ronald Cole 2004-04-13 14:11:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
installing a freshly built binary rpm results in a "segmentation fault".

Version-Release number of selected component (if applicable):
rpm-4.2.1-4.4

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild libnessus-2.0.10a-11.src.rpm
2. rpm -ivh ../RPMS/i386/libnessus*
3. rpmbuild --rebuild libnasl-2.0.10a-15.src.rpm
4. rpm -ivh ../RPMS/i386/*nasl*
5. rpmbuild --rebuild nessus-2.0.10a-14.src.rpm
6. rpm -ivh ../RPMS/i386/nessus*
    

Actual Results:  # rpm -v -ivh nessus-2.0.10a-14.i386.rpm
D: ============== nessus-2.0.10a-14.i386.rpm
D: Expected size:       257241 = lead(96)+sigs(180)+pad(4)+data(256961)
D:   Actual size:       257241
D: nessus-2.0.10a-14.i386.rpm: MD5 digest: OK
(33bfa9475a25628718223715f6b3a41d)D:      added binary package [0]
D: found 0 source and 1 binary packages
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: ========== +++ nessus-2.0.10a-14 i386-linux 0x1
D: opening  db index       /var/lib/rpm/Depends create mode=0x0
D: opening  db index       /var/lib/rpm/Basenames rdonly mode=0x0
D: opening  db index       /var/lib/rpm/Pubkeys rdonly mode=0x0
D:  read h#    1026 Header sanity check: OK
D: ========== DSA pubkey id 219180cddb42a60e
D:  read h#      32 Header V3 DSA signature: OK, key ID db42a60e
D:  Requires: /bin/sh                                       YES (db files)
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
Segmentation fault


Expected Results:  nessus-2.0.10a-14.i386.rpm should have installed
without seg faulting.

Additional info:
Comment 1 Ronald Cole 2004-04-13 14:13:21 EDT
Created attachment 99374 [details]
nessus libraries: build and install me first
Comment 2 Ronald Cole 2004-04-13 14:14:42 EDT
Created attachment 99375 [details]
nasl: build and install me second
Comment 3 Ronald Cole 2004-04-13 14:22:01 EDT
Well, bugzilla won't let me attach nessus-2.0.10a-14.src.rpm, so
you'll have to pick it all up at:

<http://forte-intl.com/~ronald/nessus/>

And don't dally, because I don't plan to keep these there for the
months and months that most of my bugzilla bug reports languish!
Comment 4 Ronald Cole 2004-04-14 20:21:25 EDT
I reckon that there's still a corruption bug in rpm-4.x.  I've never
interrupted an rpm on this machine.  Removing the __db.* from
/var/lib/rpm and issuing an "rpm --rebuild" has fixed the rpm created
corruption.

So, obviously, it was some previous rpm command which caused the
corruption.

Perhaps a new rpm feature is needed: set an environment variable to
cause rpm to perform some integrity checks before it exits, and if
corruption is found then it should be obvious that the just-ran rpm
command caused the corruption.

Note You need to log in before you can comment on or make changes to this bug.