Bug 1207496 - Activation Keys: Toggles in "Product Content" are slow - need to be more responsive or use a spinner
Summary: Activation Keys: Toggles in "Product Content" are slow - need to be more resp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-31 03:36 UTC by Corey Welton
Modified: 2019-09-25 21:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:14:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 13919 None None None 2016-04-22 15:49:39 UTC

Description Corey Welton 2015-03-31 03:36:48 UTC
Description of problem:

When user toggles an option in Activation Key > Product Content, the backend is slow to respond, but user has no indication of this in the UI.  User can end up selecting and trying to toggle the item multiple times but it never actually changes until the backend change has been made. Very confusing user experience.


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-7-20150324.0

How reproducible:


Steps to Reproduce:
1.  Create an activation key and assign content to it
2.  go to the Activation Key > Product Content subtab.
3.  Attempt to toggle various products/repos within the list that appears.

Actual results:

User can toggle multiple times, seemingly to no avail, until the backend triggers a refresh on the UI

Expected results:
Either we should be more responsive and/or flip it independent of the backend processing, or we should include some sort of spinner while the toggle is processing.

Additional info:

Comment 2 Tom McKay 2016-02-26 18:44:25 UTC
Created redmine issue http://projects.theforeman.org/issues/13919 from this bug

Comment 3 Bryan Kearney 2016-02-26 19:02:38 UTC
Upstream bug component is Content Management

Comment 4 Bryan Kearney 2016-02-26 23:02:33 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13919 has been closed
-------------
Thomas McKay
Applied in changeset commit:katello|c4c9e97ef752b2ae5355ef45708cff8fa45e59f7.

Comment 5 jcallaha 2016-03-24 19:30:34 UTC
Verified in Satellite 6.2 Beta Snap 5.1. A spinner is now shown when making the changes.

Comment 8 errata-xmlrpc 2016-07-27 09:14:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.