Bug 1207501 - Importing a new manifest does not remove old manifest entitlements from Subscriptions; error/spinner thrown on view
Summary: Importing a new manifest does not remove old manifest entitlements from Subsc...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-31 04:29 UTC by Corey Welton
Modified: 2017-02-23 20:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 14:02:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 9975 None None None 2016-04-22 15:37:02 UTC

Description Corey Welton 2015-03-31 04:29:49 UTC
Description of problem:
When importing a new manifest (after deleting old of course), the numbers for the old manifest still show up in Content > Red Hat Subscriptions.  Clicking the link for that those entitlements sends up a perma-spinner, with a big trace in logs.

Version-Release number of selected component (if applicable):

Satellite-6.1.0-RHEL-7-20150324.0

How reproducible:


Steps to Reproduce:
1.  Import a small manifest with 10 entitlements; consume some of these
2.  Delete that manifest and import a larger one with 50 entitlements.
3.  Go to Content > Red Hat subscriptions
4.  Click the link for the old (consumed) entitlements.

Actual results:

"Loading..." spinner
Big log trace (forthcoming)

Expected results:

Traces of old subscription wiped out.

Additional info:

Notably, when I move my systems over to the new inventory (i.e., it should read 4 of 50), nothing ever gets updated there, either.  Not sure if this is part of the same issue.

Comment 2 Corey Welton 2015-03-31 04:34:18 UTC
To emphasize - the old consumed entitlements do not appear to be available for consumption in Content Hosts UI.  They seem to be gone everywhere except here.

Comment 4 Mike McCune 2015-03-31 04:41:08 UTC
This may be Elasticsearch related, not getting cleaned out after the refresh of the subscriptions.

Comment 5 Steve Loranz 2015-03-31 15:44:34 UTC
Created redmine issue http://projects.theforeman.org/issues/9975 from this bug

Comment 6 Elyézer Rezende 2015-04-02 01:07:48 UTC
This happens via CLI too. Tried to delete the manifest, and it still showing some entitlements.

Comment 7 Tom McKay 2015-06-09 20:09:15 UTC
Is this reproducible any longer? My guess is that it was due to elasticsearch not getting updated to reflect the new subscriptions. This should all be working now.

Comment 8 Mike McCune 2015-06-10 14:31:51 UTC
Can't reproduce, ACKED from QE to move ON_QA

Comment 9 Corey Welton 2015-06-10 14:55:18 UTC
Comment #7 seems to be correct now, I think - I am no longer able to reproduce this. We can reopen if it rears its ugly head again.

Tested in Compose 7

Comment 10 Bryan Kearney 2015-08-11 13:28:39 UTC
This bug is slated to be released with Satellite 6.1.

Comment 11 Bryan Kearney 2015-08-12 14:02:47 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.