Bug 120755 - Cannot login because of Xsession or Xclients not executable
Cannot login because of Xsession or Xclients not executable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
athlon Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 14:41 EDT by Corey Mann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 14:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xsession-error file (454 bytes, text/plain)
2004-04-13 14:43 EDT, Corey Mann
no flags Details

  None (edit)
Description Corey Mann 2004-04-13 14:41:45 EDT
Description of problem:
I cannot login using gdm straight to gnome, I have to open a failsafe
session then, do a startx || gnome-session and it works fine (this is
as a user authenticated via an LDAP); root (from the /etc/passwd; not
LDAP) can get in just fine. This seemed to just randomly happen one
day; I used to be able to login just fine.


Version-Release number of selected component (if applicable):


How reproducible:
all the time


Steps to Reproduce:
1. type in user
2. type in pass
3. hit enter (default session or GNOME session)
  
Actual results:
x doesn't start, gives the "session started for < 10 seconds" prompt
and points me to ~/.xsessions-errors

Expected results:
Gnome to startup.

Additional info:
Sometimes I have to delete my /tmp/.X0-lock file before I can login
with the failsafe method.

I played with the Xsession file a bit (commented out line 126, and
took out the ssh-agent bit -- didn't help at all. Also tried using
switchdesk which provided the same error messages only xclients was
~/.Xclient
Comment 1 Corey Mann 2004-04-13 14:43:23 EDT
Created attachment 99378 [details]
xsession-error file

bash-2.05b$ cat .xsession-errors
/etc/X11/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/X11/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w
/var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0"
"<username removed>"
/etc/X11/xdm/Xsession: line 126: /usr/bin/ssh-agent /etc/X11/xinit/Xclients: No
such file or directory
/etc/X11/xdm/Xsession: line 126: exec: /usr/bin/ssh-agent
/etc/X11/xinit/Xclients: cannot execute: No such file or directory
bash-2.05b$ ls -al /etc/X11/xdm/Xsession
-rwxr-xr-x  1 root root 3288 Apr 13 13:33 /etc/X11/xdm/Xsession
bash-2.05b$ ls -al /etc/X11/xinit/Xclients
-rwxr-xr-x  1 root root 1914 Oct 23 21:53 /etc/X11/xinit/Xclients
Comment 2 Mike A. Harris 2004-10-12 14:12:35 EDT
I'm unable to reproduce this in the current supported release of
Fedora Core 2.

Setting status to "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.