Bug 1207583 - [GSS] (6.4.z) javax.el.BeanELResolver causes a memoryLeak when an application is redeployed
Summary: [GSS] (6.4.z) javax.el.BeanELResolver causes a memoryLeak when an application...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EE
Version: 6.3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: EAP 6.4.3
Assignee: Ingo Weiss
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1207936
TreeView+ depends on / blocked
 
Reported: 2015-03-31 09:05 UTC by Ingo Weiss
Modified: 2019-07-11 08:52 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 13:42:58 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker AS7-3736 0 Major Resolved javax.el.BeanELResolver.properties keeps references to undeployed classes (Class Loader leak) 2016-03-30 00:37:56 UTC
Red Hat Issue Tracker JBEE-133 0 Major Resolved Expression Language 3.0 (JSR-341) APIs 2016-03-30 00:37:56 UTC

Description Ingo Weiss 2015-03-31 09:05:42 UTC
This refers to https://java.net/jira/browse/GLASSFISH-17606 which was fixed here, https://java.net/projects/uel/sources/svn/revision/340 and was eventually backported to WildFly and JBoss EL 3.0 as part of JBEE-133 "Updates to v3.0 of EL API Specification" here: https://github.com/jboss/jboss-el-api_spec/commit/7178718f6cccdae451caa86ead0d146cfef9cf7d.

Can this be backport to EAP 6 by any chance? Of course this would probably make into EAP 6.4 CP01.

Comment 2 Rostislav Svoboda 2015-04-27 11:35:08 UTC
SET/GSS - please provide test (as discussed on triage) to increase CP throughput.
I will qa_ack afterwards or when the scope of CP01 is clear and we have enough seats.

Comment 7 Rostislav Svoboda 2015-04-30 13:14:23 UTC
qa_acking per Comment 5

Comment 16 Tomaz Cerar 2015-05-25 08:54:24 UTC
Yes upgrade should be reverted to 1.0.4.Final-redhat-1 as that was the version used in 6.3 and 6.4 and it was confirmed to work.

Comment 24 Vaclav Tunka 2015-05-28 09:22:34 UTC
jboss-el-api_spec was reverted to 1.0.4.Final-redhat-1 in CR3


Note You need to log in before you can comment on or make changes to this bug.