Bug 1207604 - [rfe] glusterfs snapshot cli commands should provide xml output.
Summary: [rfe] glusterfs snapshot cli commands should provide xml output.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On: 1167252
Blocks: 1245928
TreeView+ depends on / blocked
 
Reported: 2015-03-31 09:48 UTC by Mohammed Rafi KC
Modified: 2017-03-27 18:16 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1167252
: 1245928 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:16:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-03-31 09:50:25 UTC
REVIEW: http://review.gluster.org/10065 (Snapshot/xml:xml output for snapshot clone) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-04-08 05:59:39 UTC
REVIEW: http://review.gluster.org/10065 (Snapshot/xml:xml output for snapshot clone) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Vijay Bellur 2016-03-23 09:05:55 UTC
REVIEW: http://review.gluster.org/10065 (Snapshot/xml:xml output for snapshot clone) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 4 Mike McCune 2016-03-28 23:28:22 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 5 Vijay Bellur 2016-07-29 10:09:45 UTC
COMMIT: http://review.gluster.org/10065 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 8ef81bf02c779e7d126a654bde28d319d0fa823d
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Mar 31 10:54:10 2015 +0530

    Snapshot/xml:xml output for snapshot clone
    
    Snapshot clone is used to create a regular volume from snapshot.
    Currently snapshot clone is not supporting xml outout.
    
    This change introduce a xml output for snapshot clone command
    
    Change-Id: I417b480d36f9d84ee088004999b041c9619edd50
    BUG: 1207604
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/10065
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Avra Sengupta <asengupt@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 6 Shyamsundar 2017-03-27 18:16:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.