Bug 1207611 - peer probe with additional network address fails
Summary: peer probe with additional network address fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Kaushal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.7.0
TreeView+ depends on / blocked
 
Reported: 2015-03-31 10:11 UTC by Sahina Bose
Modified: 2015-05-14 17:35 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:27:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sahina Bose 2015-03-31 10:11:04 UTC
Description of problem:

When peer probing an already probed server with the additional nic, the peer probe fails. Subsequent attempts to see the gluster peer status results in "gluster peer status failed messages.




Version-Release number of selected component (if applicable):
3.7dev

How reproducible:


Steps to Reproduce:
Gluster servers having 2 NICs each. 1 in the 10.x.x.x range and the other in the 192.x.x.x range

servers were peer probed first with the 10.x.x.x addresses.
server was then peer probed using the additional interface in the 192.x.x.x range

Actual results:

Failed to recognize the additional interface

Expected results:

Comment 1 Sahina Bose 2015-03-31 10:12:57 UTC
This is required for supporting multiple networks for gluster via oVirt

Comment 2 Anand Avati 2015-04-02 17:54:25 UTC
REVIEW: http://review.gluster.org/10122 (glusterd: Better GlusterD request validation) posted (#1) for review on master by Kaushal M (kaushal@redhat.com)

Comment 3 Anand Avati 2015-04-02 17:56:25 UTC
REVIEW: http://review.gluster.org/10122 (glusterd: Better GlusterD handshake request validation) posted (#2) for review on master by Kaushal M (kaushal@redhat.com)

Comment 4 Anand Avati 2015-04-08 12:54:13 UTC
REVIEW: http://review.gluster.org/10122 (glusterd: Better GlusterD handshake request validation) posted (#3) for review on master by Kaushal M (kaushal@redhat.com)

Comment 5 Anand Avati 2015-04-09 08:35:01 UTC
REVIEW: http://review.gluster.org/10122 (glusterd: Better GlusterD handshake request validation) posted (#4) for review on master by Kaushal M (kaushal@redhat.com)

Comment 6 Anand Avati 2015-04-09 12:06:52 UTC
COMMIT: http://review.gluster.org/10122 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit e0de0cd9b24169b90c95e1f6a87f05c060185089
Author: Kaushal M <kaushal@redhat.com>
Date:   Thu Apr 2 23:06:18 2015 +0530

    glusterd: Better GlusterD handshake request validation
    
    To allow handshake requests to be validated correctly in a multi network
    environment, the request validation process has been improved.
    
    The handshake request initiator will add it's peer ID the request.
    
    The handshake request reciever will allow a request (as before) if,
    - it has no peers, or
    - the request came from a known peer
    
    Identifying the known peer is done as follows.
    - If the request contains a peer ID, it is matched against the IDs in
      the peer list. If a match is found, the request is allowed.
    - The address of the incoming request is matched against the peer
      addresses in the peer list. If a match is found, the request is
      allowed.
    - Otherwise, the request if disallowed
    
    Change-Id: I9eabe2935d16276bb147dfeebf8c8beb08e01411
    BUG: 1207611
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/10122
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 7 Niels de Vos 2015-05-14 17:27:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:28:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:35:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.