Bug 1207643 - [geo-rep]: starting the geo-rep causes "Segmentation fault" and core is generated by "gsyncd.py"
Summary: [geo-rep]: starting the geo-rep causes "Segmentation fault" and core is gener...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades 1219428
TreeView+ depends on / blocked
 
Reported: 2015-03-31 12:08 UTC by Rahul Hinduja
Modified: 2015-05-14 17:35 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1219428 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:27:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Rahul Hinduja 2015-03-31 12:08:27 UTC
Description of problem:
=======================

After starting the georep session between master and slave, the master cluster hits segfault and generates lots of core.

dmesg output:
=============

python[6122]: segfault at 308 ip 0000003f11c23128 sp 00007f76cbffd530 error 4 in libglusterfs.so.0.0.1[3f11c00000+a3000]
python[6103]: segfault at 308 ip 0000003f11c23128 sp 00007f9352d1e530 error 4 in libglusterfs.so.0.0.1[3f11c00000+a3000]
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
python[6281]: segfault at 308 ip 0000003f11c23128 sp 00007fddbadfb530 error 4 in libglusterfs.so.0.0.1[3f11c00000+a3000]
python[6268]: segfault at 308 ip 0000003f11c23128 sp 00007fcbbb459530 error 4 in libglusterfs.so.0.0.1[3f11c00000+a3000]
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
python[6384]: segfault at 308 ip 0000003f11c23128 sp 00007fc76fffd530 error 4 in libglusterfs.so.0.0.1[3f11c00000+a3000]
python[6405]: segfault at 308 ip 0000003f11c23128 sp 00007fbd11cdf530 error 4 in libglusterfs.so.0.0.1[3f11c00000+a3000]


1441 cores are generated:
=========================

[root@georep1 ~]# ls /core* | wc
   1441    1441   16862
[root@georep1 ~]# 


Version-Release number of selected component (if applicable):
=============================================================

glusterfs-server-3.7dev-0.810.gitbf8a5c9.el6.x86_64


How reproducible:
=================
1/1


Steps to Reproduce:
===================
1. Create master cluster
2. Create slave cluster
3. Create session between master and slave volume
4. Start the session between master and slave volume

Actual results:
===============

Status is shown as NA and segmentaion fault is observed.

Expected results:
=================

Status show be Active/Passive. It should not observe segmentation fault.

Comment 2 Anand Avati 2015-03-31 15:06:22 UTC
REVIEW: http://review.gluster.org/10074 (libgfchangelog: Pass correct 'this' pointer to gf_history_consume) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 3 Anand Avati 2015-04-01 06:56:56 UTC
REVIEW: http://review.gluster.org/10074 (libgfchangelog: Use correct 'this' pointer on new thread creation) posted (#2) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 4 Kotresh HR 2015-04-01 07:37:13 UTC
The two patches which handles the 'this' pointer correctly in libgfchangelog
fixes this.
http://review.gluster.org/#/c/9993/ (BUG: 1170075 : core seen with geo-rep start)
http://review.gluster.org/10074    (The core seen with history crawl)

Comment 5 Anand Avati 2015-04-01 18:53:32 UTC
REVIEW: http://review.gluster.org/10074 (libgfchangelog: Use correct 'this' pointer on new thread creation) posted (#3) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 6 Anand Avati 2015-04-02 12:11:42 UTC
REVIEW: http://review.gluster.org/10074 (libgfchangelog: Use correct 'this' pointer on new thread creation) posted (#4) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 7 Anand Avati 2015-04-02 17:31:43 UTC
REVIEW: http://review.gluster.org/10074 (libgfchangelog: Use correct 'this' pointer on new thread creation) posted (#5) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 8 Anand Avati 2015-04-03 10:30:28 UTC
COMMIT: http://review.gluster.org/10074 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 00d4125a5cb7102efeb23873cbaf155a71faa9dd
Author: Kotresh HR <khiremat@redhat.com>
Date:   Tue Mar 31 20:13:59 2015 +0530

    libgfchangelog: Use correct 'this' pointer on new thread creation
    
    When libgfchangelog is linked with non xlator application,
    it should point to 'master' xlator which is initiated separately.
    When ever a new thread is created, 'THIS' points to the global
    xlator. 'THIS' should point to corresponding xlator even then.
    This patch adjusts the pointer accordingly.
    
    Change-Id: I2a199bb3c73146a0329540aedcbae697a00f6f0a
    BUG: 1207643
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/10074
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Tested-by: Venky Shankar <vshankar@redhat.com>

Comment 9 Niels de Vos 2015-05-14 17:27:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:28:40 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:35:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.