Bug 120774 - System hangs after plugging in a WLAN-device with at76c503a driver
Summary: System hangs after plugging in a WLAN-device with at76c503a driver
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-13 20:31 UTC by Jonatan Steller
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 09:27:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonatan Steller 2004-04-13 20:31:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7b)
Gecko/20040316

Description of problem:
Hi, I don't think this to be a bug in this specific application, but
it occures while starting it. The problem could also have something to
do with the kernel. So, step by step:

After I compiled and installed the cvs-snapshot of the
at76c503a-driver (at76c503a.berlios.de) I plugged in my "T-Com T-Sinus
130 data" (a WLAN-device based uppon the "Siemens Gigaset USB card
11") that I'm used to use under Windows. The driver started correctly
and the device was registered as "wlan0" (according to syslog). But if
I now try to start the system-config-network-application to configure
the device the whole system hangs. The only way to get the system
running again is to restart the computer by pushing the power-button
for 4 seconds. Then one should plug out the device, because there's a
fatal kernel error while booting.

As I tried other applications that need to search for the wlan-device
(like the hardware explorer/manager (translated from german)) the
error also occures.

I don't think that this has something to do with the driver itself,
because it is also used for the upcomming Suse Linux 9.1 release, but
I'm a Linux-beginner, so I'm perhaps unable to judge about this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile and install the at76c503a-driver
2. plug in the device
3. try to start the application
    

Actual Results:  system hang

Expected Results:  the application should start normally

Additional info:

Comment 1 Harald Hoyer 2004-04-14 09:27:15 UTC
system-config-network uses iwconfig to configure the device... so if
this driver does not support iwconfig or crashes the system, it is the
drivers fault...


Note You need to log in before you can comment on or make changes to this bug.