Bug 120777 - Normal user unable to access /dev/cdrom for audio applications
Summary: Normal user unable to access /dev/cdrom for audio applications
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-13 20:39 UTC by Brian G. Anderson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 22:49:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian G. Anderson 2004-04-13 20:39:40 UTC
Description of problem:
With a fresh install of FC2 T2 audio utilities like gnome-cd,
sound-juicer, etc don't have enough permissions to access the cdrom
device.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Install FCT2
2. Insert an audio CD
3. start gnome-cd
  
Actual results:
Get message 
**Message: Error opening CD

Expected results:
Play the CD

Additional info:
Looking at the permissions of /dev/cdrom the owner is still root, even
though I'm logged in on X.  I checked /etc/security/console.perms and
they look identical to what they were in FC1, but perhaps selinux
changes how this works.

It doesn't seem to have anything to do with selinux since I do
"setenforcing 0" and I still can't use gnome-cd and there are no audit
messages.

Comment 1 Colin Walters 2004-05-13 19:52:06 UTC
Can you still reproduce this problem?  I can't.

Comment 2 Brian G. Anderson 2004-05-14 19:17:44 UTC
To be honest with you, I stopped trying to work under SELINUX.  So I
can't reporduce it.


Note You need to log in before you can comment on or make changes to this bug.