Bug 1207798 - [abrt] blivet-gui: ValueError: new size will not yield an aligned partition
Summary: [abrt] blivet-gui: ValueError: new size will not yield an aligned partition
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blivet-gui
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:ea90733f4181667b2ea5f8f24d5...
: 1224729 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-31 18:10 UTC by Peter Robinson
Modified: 2015-06-30 00:12 UTC (History)
2 users (show)

Fixed In Version: blivet-gui-0.2.8-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-30 00:12:00 UTC


Attachments (Terms of Use)
File: backtrace (775 bytes, text/plain)
2015-03-31 18:10 UTC, Peter Robinson
no flags Details
File: blivet-gui-tb (151.26 KB, text/plain)
2015-03-31 18:10 UTC, Peter Robinson
no flags Details
File: blivet.log (111.45 KB, text/plain)
2015-03-31 18:11 UTC, Peter Robinson
no flags Details
File: description (862 bytes, text/plain)
2015-03-31 18:11 UTC, Peter Robinson
no flags Details
File: environ (2.65 KB, text/plain)
2015-03-31 18:11 UTC, Peter Robinson
no flags Details
File: program.log (38.79 KB, text/plain)
2015-03-31 18:11 UTC, Peter Robinson
no flags Details

Description Peter Robinson 2015-03-31 18:10:54 UTC
Description of problem:
Just trying to resize a partition

Version-Release number of selected component:
blivet-gui-0.2.3-1.fc22.noarch

Additional info:
reporter:       libreport-2.5.0
blivet-gui.log: 
cmdline:        /usr/bin/python  /bin/blivet-gui
executable:     /bin/blivet-gui
hashmarkername: blivet-gui
kernel:         4.0.0-0.rc5.git1.3.fc22.x86_64
other involved packages: python-blivet-1.0.5-1.fc22.noarch
product:        Fedora
release:        Fedora release 22 (Twenty Two)
runlevel:       N 5
type:           Python
version:        22

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/blivetgui/utils.py", line 552, in edit_partition_device
    self.storage.devicetree.registerAction(ac)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 492, in registerAction
    action.apply()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 452, in apply
    self.device.targetSize = self._targetSize
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 274, in <lambda>
    lambda s, v: s._setTargetSize(v),
  File "/usr/lib/python2.7/site-packages/blivet/devices/partition.py", line 261, in _setTargetSize
    raise ValueError("new size will not yield an aligned partition")
ValueError: new size will not yield an aligned partition

Comment 1 Peter Robinson 2015-03-31 18:10:57 UTC
Created attachment 1009189 [details]
File: backtrace

Comment 2 Peter Robinson 2015-03-31 18:10:59 UTC
Created attachment 1009190 [details]
File: blivet-gui-tb

Comment 3 Peter Robinson 2015-03-31 18:11:02 UTC
Created attachment 1009191 [details]
File: blivet.log

Comment 4 Peter Robinson 2015-03-31 18:11:03 UTC
Created attachment 1009192 [details]
File: description

Comment 5 Peter Robinson 2015-03-31 18:11:04 UTC
Created attachment 1009193 [details]
File: environ

Comment 6 Peter Robinson 2015-03-31 18:11:06 UTC
Created attachment 1009194 [details]
File: program.log

Comment 7 Vojtech Trefny 2015-05-26 08:00:53 UTC
*** Bug 1224729 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2015-06-18 11:56:08 UTC
blivet-gui-0.2.8-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/blivet-gui-0.2.8-1.fc22

Comment 9 Fedora Update System 2015-06-21 00:21:28 UTC
Package blivet-gui-0.2.8-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing blivet-gui-0.2.8-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10246/blivet-gui-0.2.8-1.fc22
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-06-30 00:12:00 UTC
blivet-gui-0.2.8-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.