Bug 120788 - up2date fails due to bad GConf2 GPG sig
Summary: up2date fails due to bad GConf2 GPG sig
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: GConf2 (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-13 21:46 UTC by Landon Curt Noll
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 18:35:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Landon Curt Noll 2004-04-13 21:46:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
Up2date for RHEL3 WS Beta 2 and Extras Beta 2 fails because
the GConf2-2.2.1-4 package is signed with an unknown GPG key.

Version-Release number of selected component (if applicable):
GConf2-2.2.1-4

How reproducible:
Always

Steps to Reproduce:
1.install a RHEL3 WS 3 update 1 system with GConf2
2.add RHEL3 WS Beta 2 and Extras Beta 2 channels
3.up2date --nox -d -u
    

Actual Results:  The package GConf2-2.2.1-4 is signed, but with an
uknown GPG key. Aborting...
Package GConf2-2.2.1-4 has a unknown GPG signature.


Expected Results:  New Beta 2 RPMs would be downloaded.

Additional info:

BTW: Note the typo in the error message:

    "... but with an uknown GPG key"

Comment 1 Bill Nottingham 2004-04-14 16:16:58 UTC
What does 'rpm -vK Gconf-2.2.1-4*.rpm' say?

Comment 2 Landon Curt Noll 2004-04-14 18:06:54 UTC
rpm -vK Gconf-2.2.1-4*.rpm says nothing without a sound driver :-) 
 
However: 
 
rpm -vK GConf2-2.2.1-4.i386.rpm says: 
 
GConf2-2.2.1-4.i386.rpm: 
    Header V3 DSA signature: NOKEY, key ID 897da07a 
    Header SHA1 digest: OK 
(570f81ddca89af0cfbe88f95da391227f9d5de69) 
    MD5 digest: OK (f7615823d6fbcb1fb6cebf835e6cb225) 
    V3 DSA signature: NOKEY, key ID 897da07a 
 

Comment 3 Tim Powers 2004-04-14 18:34:49 UTC
You need to import the beta key. To do so, run this command on the machine you wish to 
update prior to running up2date:

rpm --import /usr/share/doc/rpm-4.2.2/BETA-GPG-KEY




Note You need to log in before you can comment on or make changes to this bug.