Bug 120790 - cdrecord ignores speed and selects some strange speed
cdrecord ignores speed and selects some strange speed
Status: CLOSED DUPLICATE of bug 119906
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 18:13 EDT by Richard Allen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Allen 2004-04-13 18:13:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
PS: I was unable to find a cdrecord component.


I have a HP NX7010 laptop with a CD/DVD burner.
For some reason cdrecord chooses to ignore the speed I give it and
choose some other speed.

example:

[root@xo tmp]# cdrecord --dev=/dev/hdc speed=24 -driveropts=burnfree
-eject -data yarrow-i386-disc2.iso 
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01a27-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
<warly@mandrakesoft.com>.
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.80-RH '@(#)scsi-linux-sg.c       
1.80 04/03/08 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   : 
Vendor_info    : 'SONY    '
Identifikation : 'DVD+RW DW-P50A  '
Revision       : '1.8e'
Device seems to be: Generic mmc2 DVD-ROM.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE 
Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
Starting to write CD/DVD at speed  16.0 in real TAO mode for single
session.
Last chance to quit, starting real write    0 seconds. Operation starts.
trackno=0
Track 01: Total bytes read/written: 667516928/667516928 (325936 sectors).

Meaning that cdrecord chose speed 16 even tho I requested 24.
Then I burned the third ISO.  Only change in the commandline was the
name of the file:

[root@xo tmp]# cdrecord --dev=/dev/hdc speed=24 -driveropts=burnfree
-eject -data yarrow-i386-disc3.iso 
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01a27-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
<warly@mandrakesoft.com>.
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.80-RH '@(#)scsi-linux-sg.c       
1.80 04/03/08 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   : 
Vendor_info    : 'SONY    '
Identifikation : 'DVD+RW DW-P50A  '
Revision       : '1.8e'
Device seems to be: Generic mmc2 DVD-ROM.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE 
Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
Starting to write CD/DVD at speed   4.0 in real TAO mode for single
session.
Last chance to quit, starting real write    0 seconds. Operation starts.
trackno=0
Track 01: Total bytes read/written: 645464064/645464064 (315168 sectors).


Here it chose speed 4, even tho I asked for 24.   Annoying at best ;)


Version-Release number of selected component (if applicable):
cdrecord-2.01-0.a27.2

How reproducible:
Always

Steps to Reproduce:
1. Burn a few .iso's with cdrecord in FC2 1.91 and see what happens
    

Additional info:
Comment 1 Harald Hoyer 2004-04-14 05:52:49 EDT

*** This bug has been marked as a duplicate of 119906 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.