Bug 120791 - build fails with vanilla 2.6 kernel
Summary: build fails with vanilla 2.6 kernel
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrtools   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-13 22:30 UTC by Stephen Beahm
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-24 10:07:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Beahm 2004-04-13 22:30:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
Build fails because a typedef for u8 is not in found in
/usr/src/linux/scsi.h

Kernel headers should not be included in userspace programs.

One possible solution is to patch the file
cdrtools-2.01/DEFAULTS/Defaults.linux to not include kernel headers.
This will force the use of scsi.h from glibc-headers. If this solution
is used, glibc-headers should probably have a BuildRequires entry in
the .spec file.



Version-Release number of selected component (if applicable):
cdrtools-2.01-0.a27.2

How reproducible:
Always

Steps to Reproduce:
1. install vanilla 2.6 kernel
2. create symbolic link /usr/src/linux
3. build cdrtools
    

Actual Results:  /usr/src/linux/include/scsi/scsi.h:217: error: syntax
error before "u8"

Additional info:

Comment 1 Harald Hoyer 2004-05-24 10:07:43 UTC
$ rpm -qf  /usr/include/scsi/scsi.h
glibc-headers-2.3.3-27


Note You need to log in before you can comment on or make changes to this bug.