Bug 1207937 - numa settings disapear after restart libvirtd
Summary: numa settings disapear after restart libvirtd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-01 03:35 UTC by Luyao Huang
Modified: 2015-11-19 06:26 UTC (History)
6 users (show)

Fixed In Version: libvirt-1.2.14-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:26:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2015-04-01 03:35:38 UTC
description of problem:
numa settings disapear after restart libvirtd

Version-Release number of selected component (if applicable):
libvirt-1.2.13-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
 
1.edit a vm like this:
# virsh edit r6
  <cpu>
    <numa>
      <cell id='0' cpus='0,2,4,6,8' memory='512000' unit='KiB'/>
      <cell id='1' cpus='1,3,5,7,9' memory='512000' unit='KiB'/>
    </numa>
  </cpu>

2.start it and check running vm xml:
# virsh start test3

# virsh dumpxml test3
  <cpu>
    <numa>
      <cell id='0' cpus='0,2,4,6,8' memory='512000' unit='KiB'/>
      <cell id='1' cpus='1,3,5,7,9' memory='512000' unit='KiB'/>
    </numa>
  </cpu>

3. restart libvirtd and recheck

# service libvirtd restart
Redirecting to /bin/systemctl restart  libvirtd.service

# virsh dumpxml test3
...
  <cpu/>
...

Actual results:
numa settings disapear after restart libvirtd

Expected results:
fix it

infomation:

patch was just pushed these days:

commit d75e23bbfb92793ac6828a6eff6d909c5f92cc9b
Author: Luyao Huang <lhuang@redhat.com>
Date:   Thu Mar 19 18:13:04 2015 +0800

    conf: fix parsing of NUMA settings in VM status XML
    
    Commit 5bba61f changed the XPath strings to be absolute when parsing
    the VM NUMA configuration. Unfortunately the <domain> element is not a
    top level element when parsing the domain status XML thus the absolute
    XPath string doesn't match.
    
    Use the relative string so that the <numa> settings are not lost.
    
    Signed-off-by: Luyao Huang <lhuang@redhat.com>

Comment 1 Luyao Huang 2015-04-01 05:59:21 UTC
Can not reproduce this issue with libvirt-1.2.8-16.el7_1.2 and libvirt-1.2.8-16.el7, so set regression keyword

Comment 3 Jiri Denemark 2015-04-01 06:33:15 UTC
Fixed upstream by v1.2.13-272-gd75e23b

Comment 5 Shanzhi Yu 2015-07-06 11:32:22 UTC
Verify this bug with libvirt-1.2.17-1.el7.x86_64

Comment 7 errata-xmlrpc 2015-11-19 06:26:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.