Bug 1207975 - ifup-aliases does not proper catch arping failure
ifup-aliases does not proper catch arping failure
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts (Show other bugs)
7.1
All Linux
unspecified Severity high
: rc
: ---
Assigned To: initscripts Maintenance Team
Jan Ščotka
:
Depends On:
Blocks: 1275550
  Show dependency treegraph
 
Reported: 2015-04-01 02:53 EDT by Peter Bieringer
Modified: 2016-11-25 08:04 EST (History)
6 users (show)

See Also:
Fixed In Version: initscripts-9.49.25-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: We use arping for detection of duplicate ip addresses on the network. For aliases previous check failed not only in the case that there was a duplicate address on the network, but also in the case that arping failed for some other reason. Consequence: Fix: Now we fail only in the case that there is a duplicit address on the network. Result:
Story Points: ---
Clone Of:
: 1275550 (view as bug list)
Environment:
Last Closed: 2015-11-19 06:29:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2015-04-01 02:53:24 EDT
Description of problem:
After latest EL7 updates VMs on Virtuozzo having public IPv4 addresses only configured in alias config files the IPv4 addresses are no longer applied.

Version-Release number of selected component (if applicable):
initscripts-9.49.24-1.el7.x86_64              Mi 01 Apr 2015 01:08:31 CEST

How reproducible:
always after reboot

Steps to Reproduce:
1. update initscript
2. reboot

Actual results:
Only the IPv6 address is applied, defined in
/etc/sysconfig/network-scripts/ifcfg-venet0


Expected results:
IPv4 addresses also applied from 
/etc/sysconfig/network-scripts/ifcfg-venet0:0
/etc/sysconfig/network-scripts/ifcfg-venet0:1

Additional info:

while ifup-eth is catching the return code of arping already proper, ifup-aliases still don't.

Workaround: fix script manually until a fixed initscript package is available

--- ifup-aliases.orig	2015-04-01 08:46:08.179879018 +0200
+++ ifup-aliases	2015-04-01 08:46:52.558427785 +0200
@@ -261,7 +261,8 @@
                is_available ${parent_device} && \
                ( grep -qswi "up" /sys/class/net/${parent_device}/operstate ||  grep -qswi "1" /sys/class/net/${parent_device}/carrier ) ; then
                    echo $"Determining if ip address ${IPADDR} is already in use for device ${parent_device}..."
-				   if ! /sbin/arping -q -c 2 -w ${ARPING_WAIT:-3} -D -I ${parent_device} ${IPADDR} ; then
+				   /sbin/arping -q -c 2 -w ${ARPING_WAIT:-3} -D -I ${parent_device} ${IPADDR}
+				   if [ $? = 1 ]; then
 					   net_log $"Error, some other host already uses address ${IPADDR}."
 					   return 1
 				   fi
Comment 2 Lukáš Nykrýn 2015-04-01 06:43:31 EDT
dev_ack for fixing this in 7.2
Comment 3 Alexander Tsoy 2015-04-01 10:42:38 EDT
JFYI: OpenVZ guys fixed this problem in another way:
http://git.openvz.org/?p=vzctl;a=commitdiff;h=24a0a40277542fba;hp=f4d35dde74fd74ab068e34748919ac0b9a6a21aa
But vzctl with this fix is not yet released.

Of course this does not negate the need to fix initscripts package.
Comment 4 Steve 2015-04-03 15:46:12 EDT
This needs to be fixed immediately!  There are thousands of OpenVZ containers that are broken and NOONE knows it.  When they reboot, they will be zombie OpenVZ containers with no network access.

This functionality was taken away from 17 to 24, and needs to be returned immediately.
Comment 5 Lukáš Nykrýn 2015-04-04 04:18:27 EDT
Can you please file a ticket through customer portal? That will speed things up.
Comment 6 Peter Bieringer 2015-04-04 05:53:29 EDT
I can't open a ticket because I found the issue on a private CentOS 7 system hosted @Strato - but Red Hat QA should have strong interest to get this fixed asap before all the OpenVZ containers reboot and have broken IPv4 connectivity all around the world. Container customers and support of the platform will get very unhappy then.

(I was able to fix mine by myself, because IPv6 config was defined in main ifcfg-venet0 and therefore not affected).
Comment 11 errata-xmlrpc 2015-11-19 06:29:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2134.html

Note You need to log in before you can comment on or make changes to this bug.