Bug 1207981 - [UX] error during unpacking archive does not fail the installation
Summary: [UX] error during unpacking archive does not fail the installation
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 22
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1194424 1244954 1250395 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-01 07:14 UTC by Tomas Tomecek
Modified: 2016-10-03 18:18 UTC (History)
10 users (show)

Fixed In Version: dnf-plugins-core-0.1.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-15 02:13:37 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1254834 None None None Never

Internal Trackers: 1254834

Description Tomas Tomecek 2015-04-01 07:14:42 UTC
I've tried to install `python-texttable` today and it completely blow. Funny thing is that dnf didn't care:

$ sudo dnf install python-texttable
...snip...
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : python-texttable-0.8.1-4.fc21.noarch                                                                                                                                      1/1 
Error unpacking rpm package python-texttable-0.8.1-4.fc21.noarch
error: unpacking of archive failed on file /usr/lib/python2.7/site-packages/texttable-0.8.1-py2.7.egg-info: cpio: rename
python-texttable-0.8.1-4.fc21.noarch was supposed to be installed but is not!
  Verifying   : python-texttable-0.8.1-4.fc21.noarch                                                                                                                                      1/1 

Installed:
  python-texttable.noarch 0.8.1-4.fc21                                                                                                                                                        

Complete!

How could this be successful when rpm said it can't unpack the archive?


I even rebuilt that package locally from dist-git and result was the same.


Versions:

rpm-4.12.0.1-5.fc21.x86_64
dnf-0.6.4-1.fc21.noarch

Comment 1 Honza Silhan 2015-04-02 16:18:54 UTC
Thanks for the report. We'll take a look.

Comment 2 Tomas Tomecek 2015-05-18 06:14:33 UTC
Well?

Comment 3 Tomas Tomecek 2015-06-30 12:19:45 UTC
This is still happening:

Running transaction
  Upgrading   : python-greenlet-0.4.7-1.fc22.x86_64                                                                                                      1/14 
  Upgrading   : python-gevent-1.0.2-2.fc22.x86_64                                                                                                        2/14 
  Upgrading   : python3-py-1.4.29-1.fc22.noarch                                                                                                          3/14 
  Upgrading   : python3-dap2rpm-0.1.11-1.fc22.noarch                                                                                                     4/14 
  Upgrading   : python-requests-2.7.0-1.fc22.noarch                                                                                                      5/14 
Error unpacking rpm package python-requests-2.7.0-1.fc22.noarch
error: unpacking of archive failed on file /usr/lib/python2.7/site-packages/requests/packages/chardet: cpio: rename
  Upgrading   : python-py-1.4.29-1.fc22.noarch                                                                                                           6/14 
error: python-requests-2.7.0-1.fc22.noarch: install failed
  Upgrading   : python-docker-scripts-0.4.2-1.fc22.noarch                                                                                                7/14 
  Cleanup     : python3-py-1.4.28-1.fc22.noarch                                                                                                          8/14 
  Cleanup     : python3-dap2rpm-0.1.9-1.fc22.noarch                                                                                                      9/14 
  Cleanup     : python-py-1.4.28-1.fc22.noarch                                                                                                          10/14 
error: python-requests-2.3.0-3.fc21.noarch: erase skipped
  Cleanup     : python-docker-scripts-0.4.1-1.fc22.noarch                                                                                               11/14 
  Cleanup     : python-gevent-1.0.1-2.fc22.x86_64                                                                                                       12/14 
  Cleanup     : python-greenlet-0.4.5-1.fc22.x86_64                                                                                                     13/14 
  Verifying   : python-docker-scripts-0.4.2-1.fc22.noarch                                                                                                1/14 
  Verifying   : python-gevent-1.0.2-2.fc22.x86_64                                                                                                        2/14 
  Verifying   : python-greenlet-0.4.7-1.fc22.x86_64                                                                                                      3/14 
  Verifying   : python-py-1.4.29-1.fc22.noarch                                                                                                           4/14 
python-requests-2.7.0-1.fc22.noarch was supposed to be installed but is not!
  Verifying   : python-requests-2.7.0-1.fc22.noarch                                                                                                      5/14 
  Verifying   : python3-dap2rpm-0.1.11-1.fc22.noarch                                                                                                     6/14 
  Verifying   : python3-py-1.4.29-1.fc22.noarch                                                                                                          7/14 
  Verifying   : python-docker-scripts-0.4.1-1.fc22.noarch                                                                                                8/14 
  Verifying   : python-py-1.4.28-1.fc22.noarch                                                                                                           9/14 
  Verifying   : python3-py-1.4.28-1.fc22.noarch                                                                                                         10/14 
  Verifying   : python-gevent-1.0.1-2.fc22.x86_64                                                                                                       11/14 
  Verifying   : python3-dap2rpm-0.1.9-1.fc22.noarch                                                                                                     12/14 
python-requests-2.3.0-3.fc21.noarch was supposed to be removed but is not!
  Verifying   : python-requests-2.3.0-3.fc21.noarch                                                                                                     13/14 
  Verifying   : python-greenlet-0.4.5-1.fc22.x86_64                                                                                                     14/14 

Upgraded:
  python-docker-scripts.noarch 0.4.2-1.fc22   python-gevent.x86_64 1.0.2-2.fc22      python-greenlet.x86_64 0.4.7-1.fc22   python-py.noarch 1.4.29-1.fc22  
  python-requests.noarch 2.7.0-1.fc22         python3-dap2rpm.noarch 0.1.11-1.fc22   python3-py.noarch 1.4.29-1.fc22      

Complete!

Comment 4 Honza Silhan 2015-06-30 13:10:37 UTC
As I said in comment 2.
FTR all but packages reporting errors from rpm were installed and DNF doesn't reflected this fact in the transaction summary nor in return code.

Comment 5 Honza Silhan 2015-07-03 20:33:10 UTC
*** Bug 1194424 has been marked as a duplicate of this bug. ***

Comment 6 Honza Silhan 2015-07-21 11:53:07 UTC
PR: https://github.com/rpm-software-management/dnf/pull/306

Comment 7 Fedora Update System 2015-08-10 10:05:24 UTC
dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23

Comment 8 Fedora Update System 2015-08-10 10:49:47 UTC
dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22

Comment 9 Honza Silhan 2015-08-10 12:23:56 UTC
*** Bug 1244954 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2015-08-11 02:10:59 UTC
Package dnf-plugins-core-0.1.10-1.fc22, dnf-1.1.0-1.fc22, hawkey-0.6.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.10-1.fc22 dnf-1.1.0-1.fc22 hawkey-0.6.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13162/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
then log in and leave karma (feedback).

Comment 11 Honza Silhan 2015-08-11 13:52:11 UTC
*** Bug 1250395 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2015-08-15 02:13:37 UTC
dnf-plugins-core-0.1.10-1.fc22, hawkey-0.6.0-1.fc22, dnf-1.1.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-08-19 07:51:13 UTC
dnf-plugins-core-0.1.10-1.fc23, hawkey-0.6.0-1.fc23, dnf-1.1.0-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Rudd-O DragonFear 2016-10-03 18:18:06 UTC
This keeps happening.  This is an installation of packages from Fedora 23 on a latest Fedora 24 Cloud system (using the chroot option, of course):

  Installing  : NetworkManager-1:1.0.12-2.fc23.x86_64                   203/219
  Installing  : net-tools-2.0-0.35.20150915git.fc23.x86_64              205/219
error: kbd-2.0.2-8.fc23.x86_64: install failed
  Installing  : dnf-1.1.10-1.fc23.noarch                                206/219
  Installing  : trousers-0.3.13-5.fc23.x86_64                           207/219

...

  Verifying   : vim-minimal-2:7.4.1868-1.fc23.x86_64             	 41/219
  Verifying   : cryptsetup-1.7.2-1.fc23.x86_64                           42/219
  Verifying   : kbd-misc-2.0.2-8.fc23.noarch                             43/219kbd-2.0.2-8.fc23.x86_64 was supposed to be installed but is not!

  Verifying   : kbd-2.0.2-8.fc23.x86_64                                  44/219
  Verifying   : kbd-legacy-2.0.2-8.fc23.noarch                           45/219
  Verifying   : policycoreutils-2.4-21.fc23.x86_64                       46/219

...

  vim-minimal.x86_64 2:7.4.1868-1.fc23
  which.x86_64 2.20-12.fc23
  xkeyboard-config.noarch 2.16-2.fc23
  xz.x86_64 5.2.1-3.fc23
  xz-libs.x86_64 5.2.1-3.fc23
  zlib.x86_64 1.2.8-9.fc23

Failed:
  kbd.x86_64 2.0.2-8.fc23


What gives?  Why is the error message "install failed" all I get, and no information as to what actually happened?


Note You need to log in before you can comment on or make changes to this bug.