Bug 120799 - no sound on Intel Corp. 82801DB (ICH4) AC'97 Audio Controller, module snd_intel8x0m does not deliver sound
Summary: no sound on Intel Corp. 82801DB (ICH4) AC'97 Audio Controller, module snd_int...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-13 23:51 UTC by Sergey V. Udaltsov
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 23:35:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sergey V. Udaltsov 2004-04-13 23:51:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040319 Galeon/1.3.14

Description of problem:
Loaded snd_intel8x0m module and other alsa sound modules. The sound
does not work. Earlier, I built 2.6.4 with separate snd_intel8x0m
module - and it worked, produced sound. Audio utilities just find NO
output/mixer devices. cat bla.wav > /dev/snd just hangs forever (no
craches, no "device not present" messages, nothing in dmesg).

Though, I have to admin, the software modem (slmodemd) works just fine
(actually, I am using it right now).

mixer utilities (for example, gnome-alsamixer) report device "Silicon
Laboratory Si3036/8 rev 7" (because this is what
/proc/asound/card0/codec97#0/mc97#1-1 says).

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.319

How reproducible:
Always

Steps to Reproduce:
1. Install 2.6.5-1.319 on HW with the device
2. Try any sound utilities

Actual Results:  Sound does not work

Additional info:

Comment 1 Arjan van de Ven 2004-04-14 07:27:19 UTC
snd_intel8x0m is actually the modem driver so that's not much of a
surprise :)

snd_intel8x0 is the sound driver.

Comment 2 Sergey V. Udaltsov 2004-04-14 08:31:07 UTC
Well, the prefix snd_ is somewhat misleading. So why on earth I get
this "Silicon..." device without any real sound abilities? And why cat
> /dev/dsp does not say "no such device"?

Actually, the story started when the lad who developed snd_intel8x0m
advised me to use it INSTEAD of snd_intel8x0 (then I patched kernel
myself and it worked for me).

Comment 3 Sergey V. Udaltsov 2004-04-14 23:35:07 UTC
I am an idiot. Earlier, I had both modules loaded - intel8x0m and
intel8x0. Really sorry for bother. Closing it. Just one final
question: will fc2 autodetect and autoload the modem module intel8x0m?


Note You need to log in before you can comment on or make changes to this bug.