Bug 1208018 - config-manager: enable won't work. TypeError: unorderable types: Repo() < Repo()
Summary: config-manager: enable won't work. TypeError: unorderable types: Repo() < Repo()
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1208827 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-01 08:23 UTC by Igor Gnatenko
Modified: 2015-05-08 07:27 UTC (History)
7 users (show)

Fixed In Version: dnf-plugins-core-0.1.7-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-08 07:27:14 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Igor Gnatenko 2015-04-01 08:23:43 UTC
$ sudo dnf config-manager --enable koji
Swipe your finger across the fingerprint reader
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1071, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/config_manager.py", line 108, in run
    self.modify_repo()
  File "/usr/lib/python3.4/site-packages/dnf-plugins/config_manager.py", line 144, in modify_repo
    for repo in sorted(matched):
TypeError: unorderable types: Repo() < Repo()

Comment 1 Michael Mráka 2015-04-01 08:44:01 UTC
You most likely wanted to run

sudo dnf config-manager --set-enabled koji

Anyway this is a valid bug, dnf should not fail with traceback in such situation.

Comment 2 Radek Holy 2015-04-03 10:58:51 UTC
*** Bug 1208827 has been marked as a duplicate of this bug. ***

Comment 3 Honza Silhan 2015-04-07 17:05:58 UTC
PR: https://github.com/rpm-software-management/dnf/pull/248

Comment 4 Fedora Update System 2015-05-02 13:49:38 UTC
dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22

Comment 5 Fedora Update System 2015-05-03 17:24:35 UTC
Package dnf-plugins-core-0.1.7-1.fc22, hawkey-0.5.5-1.fc22, dnf-1.0.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.7-1.fc22 hawkey-0.5.5-1.fc22 dnf-1.0.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7483/dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-05-08 07:27:14 UTC
dnf-plugins-core-0.1.7-1.fc22, hawkey-0.5.5-1.fc22, dnf-1.0.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.