Bug 12081 - Multiple X server startup woes.
Multiple X server startup woes.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-11 07:27 EDT by jlavi
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 17:46:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jlavi 2000-06-11 07:27:45 EDT
Dear Sir,

Could gdm's X server startup have delay mechanism when starting more than
one X server at the same time?

I had difficulties startubg two X servers by gdm. I am using gdm 2,0beta2 
(release 26 on RedHat 6.2).

It seems the problem was two almost simultaneously starting X servers
fighjting with each other. Only one server started, couldn't use keyboard
nor mouse properly and text virtual consoles didn't switch to text mode.
My adapter is S3 968.

On the other hand, I was ablt start two X server from command line or
by first editing gdm and then sending HUP signal gdm.

I kind of solved the problem by delaying the startup by shell wrapper:

In gdm.conf:

  [servers]
  0=/etc/X11/gdm/slowstart.sh /usr/bin/X11/X -bpp 16
  1=/etc/X11/gdm/slowstart.sh /usr/bin/X11/X -bpp 16

In slowstart.sh:

  #! /bin/sh
  if /bin/ps ax | grep -v grep | grep -q 'X.*auth' ; then
    sleep 1
  fi
  exec $*
Comment 1 Havoc Pennington 2001-07-12 17:46:27 EDT
I believe it's an X bug if this doesn't work.

Note You need to log in before you can comment on or make changes to this bug.