Bug 1208212 - Anaconda terminates on blivet's UnusableConfigurationError.
Summary: Anaconda terminates on blivet's UnusableConfigurationError.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1216053 1216208 1221777 1235528 1238825 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-01 16:33 UTC by mulhern
Modified: 2016-01-03 19:16 UTC (History)
27 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-22 12:15:29 UTC
Type: Bug
dshea: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1208135 unspecified CLOSED UnusableConfigurationError: failed to scan disk sdb 2020-10-14 00:28:05 UTC

Internal Links: 1208135

Description mulhern 2015-04-01 16:33:44 UTC
Description of problem:

Anaconda terminates with a stack trace when blivet raises UnusableConfigurationError.

Version-Release number of selected component (if applicable):

anaconda-22.20.6-1

How reproducible:

See bz#1208135 for details.

Steps to Reproduce:

ditto

Actual results:

anaconda terminates with an exception.

Expected results:

anaconda should exit a bit more elegantly.

Additional info:

See bz#1208135

Comment 1 David Shea 2015-04-24 17:54:24 UTC
Does 8b27185f47b6ab423c91b93fc5030743ecbf46b3 need to be cherry-picked to f22-branch?

Comment 2 David Shea 2015-04-28 13:28:09 UTC
*** Bug 1216053 has been marked as a duplicate of this bug. ***

Comment 3 David Shea 2015-04-28 19:17:02 UTC
*** Bug 1216208 has been marked as a duplicate of this bug. ***

Comment 4 Petr Schindler 2015-05-22 10:25:39 UTC
Another user experienced a similar problem:

This happens quite offen in first installation after I deleted raid volume in BIOS (firmware raid). GPT table was probably corrupted or non-existent at all. The corruption is probably created by firmware RAID by the way how it create and delete RAID volumes.

In any case, anaconda shouldn't crash but handle it somehow.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22-i386 quiet
dnf.rpm.log:    May 22 10:16:49 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.i686
package:        anaconda-22.20.13-1
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: corrupt gpt disklabel on disk sdc
release:        Cannot get release name.
version:        22

Comment 5 igor.bramuzzo 2015-05-28 17:28:39 UTC
Another user experienced a similar problem:

I try to install fedora 22 on my laptop but after choose the langueage the procedure gives me an unknown error, and the intallation falls. I noticed the same bug in the previous fedora 21, that i couldn't install.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdb
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 6 mouton 2015-05-28 22:45:37 UTC
Another user experienced a similar problem:

Boot to usb created using dd
Choose install to hard drive
error occurs

or

Boot to usb created using dd
choose try fedora
run install to hard drive
error occurs

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: corrupt gpt disklabel on disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 7 mouton 2015-05-29 00:05:32 UTC
Considering disk partitioning is part of the installation process, anaconda shouldn't crash or exit on a corrupt disklabel, invalid partition table, etc. but allow the user to partition the disk.

Comment 8 Silviu C. 2015-06-01 08:24:22 UTC
Another user experienced a similar problem:

I started the installer and after a few moments it crashed.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 rd.live.check
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdb
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 9 corneliu dabija 2015-06-07 02:41:28 UTC
Another user experienced a similar problem:

I just started the installation from the live CD when the error popped up.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdb
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 10 corneliu dabija 2015-06-07 23:15:48 UTC
Another user experienced a similar problem:

I just started the netinstall.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22-x86_64 rd.live.check quiet
dnf.rpm.log:    Jun 08 00:12:23 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
package:        anaconda-22.20.13-1
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdc
release:        Cannot get release name.
version:        22

Comment 11 yellowlight 2015-06-08 11:51:37 UTC
Another user experienced a similar problem:

when install Fedora 22 on the ThinkPad SL400, we can't get disk

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdc
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 12 Luc Brun 2015-06-14 10:08:20 UTC
Another user experienced a similar problem:

Durant l'install de Fedora 22. sans doute un pb avec le disque sdd

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=/isolinux/initrd0.img root=live:UUID=0237-CB30 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=/isolinux/vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 13 Viserys 2015-06-21 02:56:04 UTC
Another user experienced a similar problem:

When clicking "Install it in disk", It present.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-3 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdb
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 14 Viserys 2015-06-21 07:56:35 UTC
Another user experienced a similar problem:

When I click "install it in disk", It happened. I burn a USB storage to install my Fedora.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-3 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdb
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 15 David Shea 2015-06-22 12:15:29 UTC
rawhide includes a handler for UnusuableConfigurationError

Comment 16 Andrew F 2015-06-23 08:33:01 UTC
Another user experienced a similar problem:

Upon booting from a Fedora 22 live cd and clicking "Install to Hard Drive," the installation program immediately crashes on the language select screen. This also happens when opening the program from the activities menu.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-3 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdj
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 17 David Shea 2015-06-25 12:58:22 UTC
*** Bug 1235528 has been marked as a duplicate of this bug. ***

Comment 18 winglman 2015-07-01 21:29:14 UTC
Another user experienced a similar problem:

anaconda crach right after starting the installer at the first page.It seem to be related to my Raid array. Array1 -2drive\Raid-0  (use as storage) Array2 -1drive\RaidReady (use for win8.1) and two more drive as "single drive" i was planing to install on my 60g "single drive" but even so it just crash and the only option is to QUIT so....here i am lol

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:LABEL=UUI NULL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdf
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 19 David Shea 2015-07-02 18:09:13 UTC
*** Bug 1238825 has been marked as a duplicate of this bug. ***

Comment 20 Frank Daniel 2015-07-18 02:36:57 UTC
Another user experienced a similar problem:

Just trying to install Fedora from .iso download

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 21 Frank Daniel 2015-07-19 19:53:29 UTC
Another user experienced a similar problem:

I down loaded the fedora 22 workstation .iso from the Fedora web site and validated it.  I then burned the software onto a dvd disc, verifing  the burn.
I shut down and restarted my computer, booting fom the dvd and selected starting fedora (rather than the utility option)
At the opening GUI screen I selected using the Fedora live option.  I looked around, used the web browser, fuddled about with the Fedora preload and checked my email.
I then used the activities dropdown(?) and chose the 'Install to disk'
Processes chuned and the language window popped up.  Before I could click on continue the "Unkown error" popup came up.

I don't know what exactly is causing this problem(s).  But it does appear that many of the install scripts are failing.  Poor testing?

(OOPS....
    My software QA at SUN is showing.... Sorry
)

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 22 Frank Daniel 2015-07-19 20:17:16 UTC
I see the reason is "UnusableConfigurationError: failed to scan disk sda" or any disk?
I find this, uh, strange? Is it new hardware (not in my case), unexpected drivers (again.. not my case).

Comment 23 David Shea 2015-07-20 13:53:50 UTC
(In reply to Frank Daniel from comment #22)
> I see the reason is "UnusableConfigurationError: failed to scan disk sda" or
> any disk?
> I find this, uh, strange? Is it new hardware (not in my case), unexpected
> drivers (again.. not my case).

There may be more information in storage.log about what is causing the problem. It generally means that your current disklabel is corrupt in some way and needs to be manually cleared or corrected. Fedora 23 will have a dialog that better explains this situation.

Comment 24 corneliu dabija 2015-07-20 14:08:50 UTC
@David: Will Fedora 23 allow the user to continue by ignoring the disks with corrupt labels, in order to be able to install Fedora on valid disk? I ask this because I have three disks in my computer, and at least one of them has valid labels. But right now i can't install Fedora on it because the installer crashes. So I had to remove those drives (with corrupt labels) from the computer and after I installed Fedora, I put them back and Fedora can mount them just fine.

Comment 25 David Shea 2015-07-20 14:18:43 UTC
(In reply to corneliu dabija from comment #24)
> @David: Will Fedora 23 allow the user to continue by ignoring the disks with
> corrupt labels, in order to be able to install Fedora on valid disk?

No.

Comment 26 corneliu dabija 2015-07-20 14:28:34 UTC
Why not? What sense does it make to prevent the user from installing Fedora on a perfectly valid disk just because other disks with corrupted labels are present? Why doesn't Fedora just ignore those disks and tell the user why they are ignored?

Comment 27 corneliu dabija 2015-07-20 14:30:35 UTC
By ignore, I mean blacklist them, make it impossible for the user to attempt to install Fedora on them.

Comment 28 David Shea 2015-07-23 19:25:11 UTC
*** Bug 1221777 has been marked as a duplicate of this bug. ***

Comment 29 Frank Daniel 2015-07-26 21:17:29 UTC
A corrupt disk label???  I am sorry.  Been around since the MFM days.
If the disk label is truly corrupt. The disk won't show up. Period.
The disc drive's hardware determines the disc true label.  The firmware can be adjusted, very difficult for a user to do.  But it can't effect the hardware.

All of my hard drives are not "retail".  They were manufactured and tested as "pristine".  An old term maybe, but came with very deep diagnostics.

Well, my point is my issues are NOT hardware.

"Blacklisting" ???

That is a though that needs to be revisited.  As you put to forward, blacklisting could kill a enterprise.  There are too many examples.  Like IBM DOS, OS2, Sun x86 and so forth.

Anyway(s)*

I will continue apprising to issues.

addendum.

*  Why does everybody use 'anywaysss' when it's "anyway".  No 'S'!!!

Comment 30 Frank Daniel 2015-07-26 21:50:11 UTC
Well to test our points, I am doing a full drive reset. Hate it as it takes hours to do.

Comment 31 Frank Daniel 2015-07-26 21:50:34 UTC
Well to test our points, I am doing a full drive reset. Hate it as it takes hours to do.

Comment 32 Frank Daniel 2015-07-27 23:25:04 UTC
Well, the reset and test went perfect. I also install other Linux OS's on the disk.  Had no problems. (Well other than one trying to overwrite my windows 10 MBR & boot partion)
Tried the 21 and 22 install DVDs again.  Got the same problems during install.
Now, just for fun..  I grab an old download of Fedora 20.  Well guess what Did install and where this update is coming from. ;)
It appears somethng was lost in the upgrades.
Anyway, I just got prompted to do an update.  bye

Comment 33 Frank Daniel 2015-07-28 03:03:14 UTC
I was able to update from 20 to 21 then 22. Hmm..
Well, I about to expand upon the system.

I probably will revisit the installation images later.

Bye for now.

Comment 34 Prasenjit Das 2015-08-05 14:18:20 UTC
Another user experienced a similar problem:

Configration problem of anaconda

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=FEDORA-LIVE rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 35 David Lehman 2015-08-05 17:53:33 UTC
(In reply to corneliu dabija from comment #27)
> By ignore, I mean blacklist them, make it impossible for the user to attempt
> to install Fedora on them.

It's not as though we've done extra work to prevent blacklisting the broken disks. What we are doing (for the time being) is moving on without doing the extra work of writing code to ignore them. In most cases people should be fixing these issues. You should be able to provide a partial kickstart with an appropriate 'ignoredisk' line to proceed without the problematic disks.

Comment 36 corneliu dabija 2015-08-05 18:28:35 UTC
(In reply to David Lehman from comment #35)

I was never under the impression that you've done extra work to blacklist the broken disks. This problem started with Fedora 21. Obviously Fedora 22 has the same problem and it seems that Fedora 23 won't fix anything, it will only prevent people from automatically submitting a bug related to it. From what I read so far here it seems to me that this problem will never be fixed, because it isn't even recognized as a problem.
Do you really expect ordinary users to provide a kickstart file with the right ignoredisk options? I thought the purpose of the live DVD installation was to make the install as painless as possible.

Comment 37 V. Rotaev 2015-08-06 12:40:49 UTC
Another user experienced a similar problem:

Setup on hard drive with gpt

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-3 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdc
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 38 David Lehman 2015-08-06 18:23:38 UTC
(In reply to corneliu dabija from comment #36)
> (In reply to David Lehman from comment #35)
> 
> I was never under the impression that you've done extra work to blacklist
> the broken disks. This problem started with Fedora 21. Obviously Fedora 22
> has the same problem and it seems that Fedora 23 won't fix anything, it will

That's because it's not a bug in the installer -- it's a problem with your storage that you should resolve before trying to install any operating system. If you intentionally have storage that is so exotic as to cause this issue you should be capable of providing a kickstart.

> only prevent people from automatically submitting a bug related to it. From
> what I read so far here it seems to me that this problem will never be
> fixed, because it isn't even recognized as a problem.
> Do you really expect ordinary users to provide a kickstart file with the
> right ignoredisk options? I thought the purpose of the live DVD installation
> was to make the install as painless as possible.

That is not the purpose of the live media installation.

If ordinary users are confident enough to install an operating system I would hope they are confident enough to follow the suggested remedy included in in the error message for f23 to resolve a problem they played a role in creating. If not, I guess you can say that I failed to try hard enough to make it so they could avoid trying at all.

Comment 39 corneliu dabija 2015-08-06 18:56:17 UTC
(In reply to David Lehman from comment #38)

OK, one last question: Would F23 let me install on a *PERFECTLY VALID DISK* if other "corrupt" disks are present? How about this: F23 detects that some disks are corrupt, pops an error message letting me know which disks are bad, and then lets me proceed with the installation on the valid disk? I can see the bad disks when I do the partitioning but I know they are bad so I won't touch them when I install.

Comment 40 David Lehman 2015-08-07 21:23:25 UTC
(In reply to corneliu dabija from comment #39)
> (In reply to David Lehman from comment #38)
> 
> OK, one last question: Would F23 let me install on a *PERFECTLY VALID DISK*
> if other "corrupt" disks are present? How about this: F23 detects that some
> disks are corrupt, pops an error message letting me know which disks are
> bad, and then lets me proceed with the installation on the valid disk? I can
> see the bad disks when I do the partitioning but I know they are bad so I
> won't touch them when I install.

Not likely. I am not interested in spending more time doing work to enable people to avoid fixing real problems with their systems.

Comment 41 leonardbeckerthree 2015-08-15 14:07:48 UTC
Another user experienced a similar problem:

started to install Fedora 22 to hard drive from live cd

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: corrupt gpt disklabel on disk sdd
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 42 RJ 2015-08-27 16:35:12 UTC
Another user experienced a similar problem:

Start Fedora's anaconda installer

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/ubnkern initrd=/ubninit root=live:UUID=4666-7489 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 persistent
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.10-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 43 jesuisabhishek 2015-09-16 01:11:08 UTC
Another user experienced a similar problem:

i just downloaded the 32 bit live install image of fedora 22 and brned it to a pendrive and tried to  install from it as usual
that's it

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-i686-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 rd.live.check
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.i686
other involved packages: python-libs-2.7.9-6.fc22.i686, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.i686
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 44 jesuisabhishek 2015-09-19 15:31:17 UTC
so many have faced the error so how can this be installed

Comment 45 corneliu dabija 2015-09-19 15:52:42 UTC
(In reply to jesuisabhishek from comment #44)
> so many have faced the error so how can this be installed

Fix the labels on your hard drive or use another drive that has proper labels or install a different distro that allows you to use a hard drive that has bad labels.

Comment 46 Aleix 2015-09-29 10:07:27 UTC
Another user experienced a similar problem:

Install fedora

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:LABEL=UUI NULL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sdb
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 47 leonardbeckerthree 2015-09-29 11:43:21 UTC
(In reply to leonardbeckerthree from comment #41)
> Another user experienced a similar problem:
> 
> started to install Fedora 22 to hard drive from live cd
> 
> cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst
> --method=livecd:///dev/mapper/live-base
> cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img
> root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro
> rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
> hashmarkername: anaconda
> kernel:         4.0.4-301.fc22.x86_64
> other involved packages: python-libs-2.7.9-6.fc22.x86_64,
> python-blivet-1.0.9-1.fc22.noarch
> package:        anaconda-core-22.20.13-1.fc22.x86_64
> packaging.log:  
> product:        Fedora
> reason:         UnusableConfigurationError: corrupt gpt disklabel on disk sdd
> release:        Fedora release 22 (Twenty Two)
> version:        22

I Found the issue with this. I have a revodrive (HDD+SSD) that was causing the issue. I ejected the disk and the install [proceeded with no issue. Once installed I loaded the drive and it was recognized by Fedora.

Comment 48 Yi Zun 2015-10-21 06:41:11 UTC
Another user experienced a similar problem:

just want to install Fedora 22 to intel SSD 535 240GB

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-3 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: corrupt gpt disklabel on disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 49 Frank Daniel 2015-10-26 21:36:45 UTC
OK. I got some free time again.  So I'm back.
Did buy a brand new disk.  Got it for a number of reasons, but one was first.
I attempt to install 22 on it but got the same ending:

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

New disk with a corrupt label... Riight...

Using Acrionis I cleared the disk and reset the "label" to a mbr structure.
Got the same problem..  Hmmm.
Using Acrionis I cleared the disk and reset the "label" to a gpt structure
Got the same problem!!

Seems dlehman@redhat.com needs to do some splaining to do.

Just my two and a quarter (ain't inflation terrible)

Comment 50 David Lehman 2015-10-27 13:03:29 UTC
If you upload the logs I can tell you what the problem is/was.

Comment 51 Hemanshu Patel 2015-11-02 18:53:19 UTC
Another user experienced a similar problem:

Installation using LiveUSB from Fedora 22 ISO

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-blivet-1.0.10-1.fc22.noarch, python-libs-2.7.10-8.fc22.x86_64
package:        anaconda-core-22.20.13-1.fc22.x86_64
packaging.log:  
product:        Fedora
reason:         UnusableConfigurationError: failed to scan disk sda
release:        Fedora release 22 (Twenty Two)
version:        22

Comment 52 Frank Daniel 2015-11-09 23:47:50 UTC
Sorry Dave;

   I had to move on.  Got a client that MUST have Gentoo on a single laptop, and she willing to pay.

   Have you ever looked at Gentoo???  The info and manuals are like playing "Shoot the Wumpus. But with no feedback.

   I will try again later and extract all the logs I can.

Regards
Frank


Note You need to log in before you can comment on or make changes to this bug.