Bug 1208307 - Adding ECC support to OpenJDK 8 through NSS+SunEC
Summary: Adding ECC support to OpenJDK 8 through NSS+SunEC
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.8.0-openjdk   
(Show other bugs)
Version: 6.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Andrew John Hughes
QA Contact: Lukas Zachar
Lenka Špačková
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 1172231 1271375
TreeView+ depends on / blocked
 
Reported: 2015-04-01 23:29 UTC by Tim Mooney
Modified: 2016-06-05 23:16 UTC (History)
9 users (show)

Fixed In Version: java-1.8.0-openjdk-1.8.0.71-4.b15.el6
Doc Type: Release Note
Doc Text:
OpenJDK 8 now supports ECC With this update, OpenJDK 8 supports Elliptic Curve Cryptography (ECC) and the associated ciphers for TLS connections. ECC is in most cases preferable to older cryptographic solutions for making secure network connections. Additionally, the java-1.8.0 package priority has been expanded to 7 digits.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 21:03:12 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0816 normal SHIPPED_LIVE java-1.8.0-openjdk bug fix and enhancement update 2016-05-10 22:39:37 UTC
Red Hat Bugzilla 1167153 None CLOSED java-1.8.0-openjdk - unexpected exception found in the openjdk 1.8.0 2019-04-11 14:53 UTC

Description Tim Mooney 2015-04-01 23:29:40 UTC
Description of problem:

First, this bug isn't with "rh-java-common", but I couldn't choose "java-1.8.0-openjdk" because you need to add "java-1.8.0-openjdk" and related packages to the list of potential "Component" choices for Red Hat Software Collections, since that's been part of SCL since RHEL 6.6.

java-1.8.0-openjdk from SCL 1.1 on RHEL 6.6 is unable to connect to external sites that use certain encryption algorithms.  The issue is the same as the one described in this Fedora bug report:

    https://bugzilla.redhat.com/show_bug.cgi?id=1167153

How reproducible:

Always, when connecting to a site that offers elliptic curve algorithms with https.

Steps to Reproduce:
Multiple different methods of reproducing this issue are listed in the bug ID quoted above.

For example, when our continuous integration system tries to connect to Maven Central to download jars, the connection fails with:

        Caused by: java.security.NoSuchAlgorithmException: EC
AlgorithmParameters not available
                at
sun.security.jca.GetInstance.getInstance(GetInstance.java:159)
                at java.security.Security.getImpl(Security.java:695)
                at
java.security.AlgorithmParameters.getInstance(AlgorithmParameters.java:146)
                at sun.security.util.ECUtil.getECParameters(ECUtil.java:139)
                ... 53 more

Comment 3 Joe Orton 2015-06-08 11:26:15 UTC
Re-assigned to java-1.8.0-openjdk.

Comment 5 Andrew John Hughes 2015-06-08 15:19:16 UTC
ECC support will appear in java-1.7.0-openjdk in RHEL 6.7. The work now needs forward-porting to java-1.8.0-openjdk. I expect this to appear during the RHEL 6.8 timeframe.

Comment 14 errata-xmlrpc 2016-05-10 21:03:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0816.html


Note You need to log in before you can comment on or make changes to this bug.