Bug 120834 - unquoted XVENDORNAME causes the build failure
unquoted XVENDORNAME causes the build failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 08:10 EDT by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 07:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2004-04-14 08:10:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6)
Gecko/20040401 Debian/1.6-4

Description of problem:
When I'm building Canna, this problem appears. Makefile, which was
generated from Imakefile actually has quoted define for XVENDORNAME.
but when it's used actually, no quoted. so gcc is going to deal with
those arguments as unintended arguments.
Here is a log what happened.

configure:1671:  gcc  -O2 -fno-strength-reduce -fno-strict-aliasing  
-I/usr/X11R6/include -Dlinux -D__amd64__ -D_POSIX_C_SOURCE=199309L
-D_POSIX_SOURCE -D_XOPEN_SOURCE -D_BSD_SOURCE -D_SVID_SOURCE
-DFUNCPROTO=15 -DNARROWPROTO -DXVENDORNAME=The X.Org Foundation
-DXVENDORNAMESHORT=X.Org   conftest.c  >&5
gcc: X.Org: No such file or directory
gcc: Foundation: No such file or directory


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.build Canna
2.
3.
    

Actual Results:  failed

Expected Results:  build should be done completely

Additional info:
Comment 1 Mike A. Harris 2004-04-19 21:02:54 EDT
Tracking issue in upstream bug report:
    http://pdx.freedesktop.org/cgi-bin/bugzilla/show_bug.cgi?id=479

Setting status to "UPSTREAM", will review upstream status in
future.
Comment 2 Mike A. Harris 2004-09-01 07:38:57 EDT
Status update: Upstream bug report is flagged as FIXED in CVS, and
we're now using the CVS code in rawhide.

Setting status to "RAWHIDE".

Note You need to log in before you can comment on or make changes to this bug.