Bug 1208399 - dnf-3 copr enable plautrba/selinux: NameError: name 'raw_input' is not defined
dnf-3 copr enable plautrba/selinux: NameError: name 'raw_input' is not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
: 1208673 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-02 03:45 EDT by Petr Lautrbach
Modified: 2015-04-21 15:26 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.6-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-21 15:26:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Lautrbach 2015-04-02 03:45:44 EDT
# dnf install dnf-plugins-core.noarch
...
Installed:
  dnf-plugins-core.noarch 0.1.6-2.fc23  python3-dnf-plugins-core.noarch 0.1.6-2.fc23                                                                              
Complete!

# dnf copr enable plautrba/selinux   
Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1064, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/copr.py", line 111, in run
    Do you want to continue? [y/N]: """)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/copr.py", line 179, in _ask_user
    answer = raw_input(question).lower()
NameError: name 'raw_input' is not defined
Comment 1 Radek Holy 2015-04-02 04:02:36 EDT
Yet another Python 3 incompatibility :( Mirek, can you please take a look?
Comment 2 Miroslav Suchý 2015-04-02 09:31:11 EDT
Fixed in commit:
* 2772c9e migrate raw_input() to Python3 (RhBug:1208399)
Comment 3 Parag Nemade 2015-04-03 00:02:29 EDT
*** Bug 1208673 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2015-04-09 10:40:59 EDT
dnf-plugins-core-0.1.6-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.6-3.fc22
Comment 5 Fedora Update System 2015-04-10 14:21:28 EDT
Package dnf-plugins-core-0.1.6-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.6-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5951/dnf-plugins-core-0.1.6-3.fc22
then log in and leave karma (feedback).
Comment 6 Lokesh Mandvekar 2015-04-11 02:06:45 EDT
This works as expected for me now on rawhide. Thanks!
Comment 7 Fedora Update System 2015-04-21 15:26:04 EDT
dnf-plugins-core-0.1.6-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.