Bug 1208483 - eclipse does not build on ppc64/s390(x)
Summary: eclipse does not build on ppc64/s390(x)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 22
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-02 11:33 UTC by Ngo Than
Modified: 2015-08-18 05:17 UTC (History)
10 users (show)

Fixed In Version: cbi-plugins-1.1.2-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-18 05:17:37 UTC


Attachments (Terms of Use)

Description Ngo Than 2015-04-02 11:33:51 UTC
eclipse doesn't build on because of missing dependencies.

DEBUG util.py:391:  Error: No Package found for eclipse-ecf-core >= 3.9.2-2
DEBUG util.py:391:  Error: No Package found for eclipse-emf-core >= 1:2.10.2-1
DEBUG util.py:391:  Error: No Package found for osgi(org.eclipse.jetty.continuation) >= 9.2.9
DEBUG util.py:391:  Error: No Package found for osgi(org.eclipse.jetty.http) >= 9.2.9
DEBUG util.py:391:  Error: No Package found for osgi(org.eclipse.jetty.io) >= 9.2.9
DEBUG util.py:391:  Error: No Package found for osgi(org.eclipse.jetty.security) >= 9.2.9
DEBUG util.py:391:  Error: No Package found for osgi(org.eclipse.jetty.server) >= 9.2.9
DEBUG util.py:391:  Error: No Package found for osgi(org.eclipse.jetty.servlet) >= 9.2.9
DEBUG util.py:391:  Error: No Package found for osgi(org.eclipse.jetty.util) >= 9.2.9 


for more infos please take a look at:
http://ppc.koji.fedoraproject.org/kojifiles/work/tasks/8680/2408680/root.log

Comment 1 Alexander Kurtakov 2015-04-02 11:45:04 UTC
This is not eclipse bug it's builders not yet catched up on dependencies. Once eclipse-ecf/eclipse-emf/jetty versions are uptodate retry the build.

Comment 2 Mat Booth 2015-04-02 12:03:43 UTC
Alex is right.

Secondary arm is able to pretty much keep up fine: http://arm.koji.fedoraproject.org/koji/packageinfo?packageID=1533

I wonder why not ppc?

Comment 3 Mat Booth 2015-04-22 11:55:51 UTC
Hi Ngo, did you build the missing dependencies for these platform yet?

Comment 4 Ngo Than 2015-04-22 12:12:15 UTC
i will try to build it today and will report the results soon

Comment 5 Ngo Than 2015-04-29 15:57:42 UTC
Hi Mat,

eclipse-4.4.2-5 has build requires on eclipse-ecf-3.9.3 and eclipse-emf-2.10.2 and both do not build on ppc64/s390(x).

i have open bugs for both components, you can have a look at:

https://bugzilla.redhat.com/show_bug.cgi?id=1217126
https://bugzilla.redhat.com/show_bug.cgi?id=1217134

Comment 6 Fedora Update System 2015-08-12 10:55:58 UTC
cbi-plugins-1.1.2-3.fc22, tycho-extras-0.23.0-2.fc22, tycho-0.23.0-5.fc22.2, eclipse-4.5.0-5.fc22, eclipse-ecf-3.10.0-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-11679/eclipse-4.5.0-5.fc22,eclipse-ecf-3.10.0-5.fc22,cbi-plugins-1.1.2-3.fc22,tycho-extras-0.23.0-2.fc22,tycho-0.23.0-5.fc22.2

Comment 7 Fedora Update System 2015-08-13 16:56:08 UTC
Package cbi-plugins-1.1.2-3.fc22, tycho-extras-0.23.0-2.fc22, tycho-0.23.0-5.fc22.2, eclipse-4.5.0-5.fc22, eclipse-ecf-3.10.0-5.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cbi-plugins-1.1.2-3.fc22 tycho-extras-0.23.0-2.fc22 tycho-0.23.0-5.fc22.2 eclipse-4.5.0-5.fc22 eclipse-ecf-3.10.0-5.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11679/eclipse-4.5.0-5.fc22,eclipse-ecf-3.10.0-5.fc22,cbi-plugins-1.1.2-3.fc22,tycho-extras-0.23.0-2.fc22,tycho-0.23.0-5.fc22.2
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-08-18 05:17:37 UTC
cbi-plugins-1.1.2-3.fc22, tycho-extras-0.23.0-2.fc22, tycho-0.23.0-5.fc22.2, eclipse-4.5.0-5.fc22, eclipse-ecf-3.10.0-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.