Bug 120850 - Missing online resize of ext2/ext3 (e2fsadm fail)
Missing online resize of ext2/ext3 (e2fsadm fail)
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lvm (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 11:15 EDT by Petter Reinholdtsen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 11:40:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petter Reinholdtsen 2004-04-14 11:15:38 EDT
Description of problem:

  When a filesystem fills up on a server running a service
  we can't take down, it would be nice being able to extend the
  file system without umounting it.  I tried using e2fsadm on a
  test machine, but it complained that ext2online is missing:

    hvelvet.uio.no# df -h /dev/datavg/filelog
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/datavg/filelog    14G  815M   13G   7% /usit/hvelvet/filelog
    hvelvet.uio.no# e2fsadm -L 15g /dev/datavg/filelog
    e2fsadm -- Sorry: 'ext2online' not found in any of /sbin /usr/sbin /usr/local/sbin /bin /usr/bin
    e2fsadm -- ERROR: can't online resize

    e2fsadm -- ERROR: /proc/mounts says /dev/datavg/filelog is mounted on /usit/hvelvet/filelog.
    Please unmount it to resize.

    hvelvet.uio.no#

  I'm unable to find an official package from redhat including
  ext2online.  I found a version at
  <URL: http://ext2resize.sourceforge.net/ >, but we want to use
  official and supported tools on these machines.  Besides, I read
  that a kernel patch is needed as well, and we need to stay with
  the official kernel images from RedHat to make sure we get
  support from the application vendors.

  So my problem is the lack of ext2online and patched kernel
  in RedHat Enterprise Linux.  Please include it in version 3
  as soon as possible.

Version-Release number of selected component (if applicable):

  lvm-1.0.3-15
  e2fsprogs-1.32-15
  kernel-smp-2.4.21-9.EL

How reproducible:

  Every time.
Comment 1 Stephen Tweedie 2004-04-14 11:40:28 EDT
This not a bug, it's a new feature request, and as such is appropriate
for the next version of RHEL.  We do not plan to back-port this to RHEL-3.

Note You need to log in before you can comment on or make changes to this bug.