Bug 120857 - file not found error during install of kernel-source module
Summary: file not found error during install of kernel-source module
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-14 15:51 UTC by Rick Greene
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 21:28:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump file created at crash time (84.66 KB, text/plain)
2004-04-14 15:52 UTC, Rick Greene
no flags Details

Description Rick Greene 2004-04-14 15:51:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
Custom install CD was created.  Process used: downloaded AS2.1 Update
3 CDs.  Mounted iso files with "-o loop".  Created empty directory,
copied entire contents of each iso file to that directory.  Disk 3
first, then Disk 2, then Disk 1.  Removed SRPMS directory.  Removed
all unwanted RPMs from the RedHat/RPMS directory.  Used mkisofs to
create new bootable iso file:
cd /var/www/html/as21custom
mkisofs \
        -A "R&B Red Hat Linux/2.1 i386" \
        -V "R&B Red Hat Linux/2.1 i386" \
        -J -R -v -T -o /rpms/custom_as21.iso \
        -b isolinux/isolinux.bin \
        -c isolinux/boot.cat \
        -no-emul-boot -boot-load-size 4 -boot-info-table \
        .
CD boots fine, and I am able to do "linux ks=floppy" to use a ks.cfg
kickstart file on a floppy.  Install proceeds through all steps
including partitioning & formatting filesystems without error.  About
50% of requested packages install, including the kernel and kernel-smp
packages.  During the install of kernel-source, the error occurrs. 
Message of import seems to be:
IOError: [Errno 2] No such file or directory: '/mnt/source/.disc1-i386'

I will attach the full saved dump once the bug is fully submitted.

Version-Release number of selected component (if applicable):
kernel-source-2.4.9-e.34.i386

How reproducible:
Always

Steps to Reproduce:
1. Boot custom install CD (see Description for how it is created)
2. execute "linux ks=floppy"
3. error occurrs during package install
    

Actual Results:  see Description

Expected Results:  should have gotten a good install

Additional info:

Comment 1 Rick Greene 2004-04-14 15:52:59 UTC
Created attachment 99410 [details]
Anaconda dump file created at crash time

Comment 2 Jeremy Katz 2004-04-14 21:28:49 UTC
Your CD is poorly formed.  You need to have the .discn-arch files (and
also, I'm guessing you need to rerun genhdlist so that it doesn't
think that packages are on different cds).

This isn't really supported, though.


Note You need to log in before you can comment on or make changes to this bug.