Bug 1208586 - reimplement rlWaitForSocket not to use netstat if possible
Summary: reimplement rlWaitForSocket not to use netstat if possible
Keywords:
Status: CLOSED DUPLICATE of bug 1205330
Alias: None
Product: Fedora
Classification: Fedora
Component: beakerlib
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jakub Prokes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1173652 Fedora-beakerlib
TreeView+ depends on / blocked
 
Reported: 2015-04-02 15:16 UTC by Dalibor Pospíšil
Modified: 2015-04-16 08:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1205330
Environment:
Last Closed: 2015-04-16 08:24:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1205330 None None None Never

Internal Links: 1205330

Description Dalibor Pospíšil 2015-04-02 15:16:46 UTC
+++ This bug was initially created as a clone of Bug #1205330 +++

Description of problem:
SSA - if there is not net-tools package installed, rlWaitForSocket fails; it does not get installed on RHEL-7 unless it is explicitly required by some beaker test

Version-Release number of selected component (if applicable):
beakerlib-1.10-2.el7eso.noarch

How reproducible:
always

Steps to Reproduce:
1. create test using rlWaitForSocket
2. run it on clean RHEL-7 machine

Actual results:
:: [ 13:20:20 ] :: [ INFO    ] :: rlWaitForSocket: Waiting max 20s for socket `6608' to start listening
/usr/share/beakerlib/synchronisation.sh: line 190: netstat: command not found

Expected results:
rlWaitForSocket works as expected

Additional info:
I suggest to consider adding net-tools package to beakerlib dependencies

Comment 1 Hubert Kario 2015-04-15 16:10:47 UTC
I'd say this is exact duplicate of bug 1205330, vote for close


Note You need to log in before you can comment on or make changes to this bug.