Bug 120859 - Mouse not working with 2.6.5 versions
Mouse not working with 2.6.5 versions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 12:38 EDT by Mikael Carneholm
Modified: 2015-01-04 17:05 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 11:26:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vxx (8.10 KB, text/plain)
2004-09-07 18:42 EDT, Troy Davisson
no flags Details
dmidecode (15.51 KB, text/plain)
2004-09-07 18:55 EDT, Troy Davisson
no flags Details

  None (edit)
Description Mikael Carneholm 2004-04-14 12:38:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040115 Epiphany/1.0.7

Description of problem:
When updating the kernel from 2.6.1 to 2.6.5, X can't start due to
failing to load the core pointer (the mouse).

START /var/log/XFree86.0.log.old

(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(**) Option "Protocol" "PS/2"
(**) Mouse0: Protocol: "PS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/psaux"
(EE) xf86OpenSerial: Cannot open device /dev/psaux
        No such device.
(EE) Mouse0: cannot open input device
(EE) PreInit failed for input device "Mouse0"
(II) UnloadModule: "mouse"
(II) Keyboard "Keyboard0" handled by legacy driver
(**) Option "Protocol" "IMPS/2"
(**) DevInputMice: Protocol: "IMPS/2"
(**) Option "AlwaysCore"
(**) DevInputMice: always reports core events
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) DevInputMice: ZAxisMapping: buttons 4 and 5
(**) DevInputMice: Buttons: 5
(WW) No core pointer registered
(II) XINPUT: Adding extended input device "DevInputMice" (type: MOUSE)
(II) DevInputMice: ps2EnableDataReporting: succeeded
No core pointer
 
Fatal server error:
failed to initialize core devices

END /var/log/XFree86.0.log.old

Mouse works fine with 2.6.1-1.65, problem present only with 2.6.5 kernels.

NOTE: My box is a little "unorthodox" - it's a Shuttle ST62K featuring
the (still quite new) ATI RS300 chipset.



Version-Release number of selected component (if applicable):
2.6.5-1.315, 2.6.5-1.322

How reproducible:
Always
Comment 1 Joseph Kelch 2004-04-26 12:40:11 EDT
Same problem here on a DFI PW65-S (550Mhz slot 1 pentium III) i810 
chipset and a generic (Hewlett Packard) wheel mouse.
Comment 2 Richard Lloyd 2004-04-29 19:16:51 EDT
I'm getting the same problem with my 3-button HP PS/2 mouse (no scroll
wheel). The mouse has a part number of 1150-1835 and is from an old
HP-UX workstation (now fitted onto an Intel PC). Red Hat 8, 9.0,
Fedora Core 1, Fedora Core 2 Test 1 or 2 - all have worked perfectly
with the mouse. However, FC 2 Test 3 - the first to use the 2.6.5
kernel - does *not* recognise the mouse (even re-jigging the xorg.conf
to look "more like" the FC1 XF86Config didn't help), both during
installation [yes, I had to use text mode install !!] and also once
FC2T3 is up and running. I got exactly the same log errors as the
original poster, so I won't repeat them here.

BTW, this bug is similar to 122034 - I think the 2.6.5 kernel and/or
FC2T3 have *major* problems with PS/2 mice! This one really is a major
showstopper for FC2 final, IMHO.
Comment 3 Alan Cox 2004-05-02 20:54:18 EDT
The new FC2 stuff doesn't use /dev/psaux instead PS/2 mice are routed
to /dev/input/mice. Make that your core pointer.
Comment 4 Dan Stromberg 2004-05-18 19:47:01 EDT
It's not working for me whether I put /dev/psaux, /dev/input/mice,
/dev/input/mouse, /dev/input/mouse0, /dev/input/mouse1, /dev/mouse,
/dev/ttyS0, /dev/ttyS1 or /dev/psmouse.  I've tried protocols PS/2 and
IMPS/2.  I'm making these changes in /etc/X11/xorg.conf - is that the
right place?

I'm using a logitech mouseman serial-mouseport, with a ps/2 connector.

system-config-mouse isn't helping either.
Comment 5 Dan Stromberg 2004-05-19 12:49:14 EDT
I tried two more test cases.

1) I booted the first install cdrom of fc2 at home, with a logitech 3
button mouse.  It worked fine.  I didn't finish the install, because I
didn't have time, but at least the installer had mouse.

2) I tried a two-button dell mouse that says logitech on the back on
one of the work systems (the same one I mentioned in a previous
comment), and it still didn't work.  mouseconfig detected it as a
serial mouse, but statserial on ttyS0 and ttyS1 shows nothing when I
move the mouse.  I also tried booting the first install cdrom with
this mouse, and the mouse cursor just sits there.

The system is working has a SiS chipset (tried one mouse).  The system
that isn't working (tried 3 mice) has a VIA chipset.

Comment 6 Dan Stromberg 2004-05-20 00:26:27 EDT
Another test case:

I booted my other home machine using the first fedora core 2 install
cdrom, with a VIA KT133/KM133 chipset, again using the same mouse that
worked with my SiS chipset machine.  It worked.  This is still the
same logitech 3 button mouse.
Comment 7 Dan Stromberg 2004-05-20 12:38:07 EDT
Yet another test case:

I brought my mouse from home and tried it on the work machine that has
been having mouse problems with FC2.  The mouse that worked on two
different machines at home with FC2 (SiS and Via KT133/KM133), did not
work on the office machine I've been trying with FC2 (also Via
KT133/KM133).
Comment 8 Dan Stromberg 2004-05-20 21:05:56 EDT
I tried adding psmouse.proto=imps2 to the kernel flags list in
grub.conf.  It didn't help.

I tried turning off gpm in runlevel 5.  It didn't help.

I couldn't find a "BIOS USB Legacy Support" in my BIOS setup, so I
didn't set it to no.  I didn't think "enable USB mouse" was relevant.
 It was set to enabled; I didn't change it.

Comment 9 Jack Spaar 2004-05-20 22:26:02 EDT
I having this problem too on an upgrade from FC1 to FC2final.
ps/2 mouse stopped working, but USB mouse works ok.
Haven't checked BIOS settings (but ps/2 mouse worked fine in FC1).
Running /usr/sbin/fix-mouse-psaux doesn't fix it.

Several others are having this problem on fedora-list and out in the
forums:

http://www.redhat.com/archives/fedora-list/2004-May/msg03934.html
http://www.redhat.com/archives/fedora-list/2004-May/msg04449.html
Comment 10 Jack Spaar 2004-05-21 03:23:14 EDT
Update: disabling USB legacy in BIOS fixed this issue for me in FC2.
Comment 11 Dan Stromberg 2004-05-21 13:57:04 EDT
I also just tried booting with psmouse.proto=bare and (on different
boots) psmouse.proto=exps.  Neither worked.

I also tried the protocol list found in psmouse-base.c, in xorg.conf:
PS/2, PS2++, PS2T++, GenPS/2, ImPS/2, ImExPS/2 and SynPS/2.  None of
them worked, and some of them were identified as unknown protocols.

Is psmouse-base.c even being used?

I see no kernel modules in lsmod with the string "mouse" or "mice" in
them.  What module is supposed to be getting loaded to handle
/dev/input/mice?

I also tried booting with noapic nolapic on the kernel command line,
but this didn't help either.  It seems like a longshot, but I'll try
just about anything at this point.  :)
Comment 12 Dan Stromberg 2004-05-21 14:05:27 EDT
I also tried booting with "hwprobe=-c03:*:*" on the kernel cmdline,
but this didn't help either.
Comment 13 Dan Stromberg 2004-05-21 14:22:26 EDT
dmesg | egrep -i 'mouse|mice' gives:
mice: PS/2 mouse device common for all mice
input: ImPS/2 Generic Wheel Mouse on isa0060/serio1

However, my mouse is not a wheel mouse.  Could the problem be that the
kernel wants my mouse to be a wheel mouse, when it isn't?  Is there
some way I can force the kernel to see my mouse as a plain 3 button
mouse with no wheel?

Also, insmod'ing sermouse.ko doesn't appear to help matters.
Comment 14 Dan Stromberg 2004-05-21 14:31:34 EDT
gnome-mouse-properties didn't -appear- to have anything useful.  Is
there some other gnome utility that might be helpful?
Comment 15 Dan Stromberg 2004-05-21 14:46:46 EDT
I tried commenting out the ZAxisMapping line in xorg.conf since I
don't have a wheel mouse, but that didn't help either.
Comment 16 Dan Stromberg 2004-05-21 14:53:54 EDT
Just noticed that I don't have a mouse listed in my /proc/interrupts.
 Is this a good clue to someone out there?
Comment 17 Dan Stromberg 2004-05-21 15:03:09 EDT
I finally went back and disabled "USB mouse support" and "USB keyboard
support", and at last my mouse is working.  I didn't try this before
because it didn't have the word "legacy" in it, but I guess I should
have given it a try anyway.  :)

I'm very pleased to finally have a solution.
Comment 18 Sven Schuster 2004-05-21 15:51:10 EDT
I'm having similar problems since upgrading from FC1 to FC2: my
MS IntelliMouse PS/2 worked without any problems on FC1. After upgrading
to FC2, there isn't any chance to do some real work with the mouse any
more. When you move it too fast it will jump around on screen and also
randomly behave like I've pushed the mouse buttons. And the mouse
buttons also don't work. I have to push it several times until it really
"clicks". I've tried changing the configuration with mouseconfig (worked
on my RH 7.3 laptop where I had similar issues after changing/unplugging
the PS/2 mouse), without any improvement. BTW, the mouse also doesn't
work on the console with gmp. Same effect.
Comment 19 John Lagrue 2004-05-21 17:02:02 EDT
I'm running FC2 on an Acer TravelMate 225X and am getting the same
problems as outlined in this thread with both an Microsoft
Intellimouse and with the Synaptics touchpad. It is worse with the
mouse than with the pad.

Comment 20 Jim Richardson 2004-05-23 01:26:25 EDT
I am not sure this is the same, but I just completed a fresh install
of FC2 and now I cannot get my wheel mouse to scroll up it scrolls
down just fine, and seems to work in all other fashions. It was ( and
is ) working fine in FC1.
Comment 21 Jim Richardson 2004-05-23 09:36:20 EDT
Just as a followup to my comment last night, I discovered the
following kernel parameter resolves my Logiteh mouse issues.
psmouse.proto=imps Please note that it is imps NOT imps2 which does
not work.
Comment 22 Phil Schaffner 2004-05-25 17:09:47 EDT
Upgraded FC1 to FC2 on IBM A21p notebook with Logitech PS/2 mouse. 
GPM worked on VCs but X would not start.  Was no xorg.conf in /etc/X11
so first tried renaming XF86Config and running system-config-display.
 Only offered 800x600 or 640x480 resolutions.  Copied old FC1
XF86Config to xorg.conf but system-config-display failed with
complaints about mouse.  Edited xorg.conf, changed /dev/psaux to
/dev/input/mice, tried system-config-display again - this time it ran
and allowed me to select 1600x1200 and Thousands of colors, but hung
and did not exit X when closing config window.  Killed X with
Ctrl-Alt-Bksp and tried startx which works, but gives 9 XKB error
popups when Gnome starts as root, then seems to work.   KDE works OK.
Comment 23 Stefan Seefeld 2004-06-09 03:33:07 EDT
just to add another voice to the 'me too' list:

I have a logitech ps/2 mouse as well as an intuos wacom.
Both used to work fine under RH9 (the mouse under /dev/psaux
and the tablet under /dev/input/event0), but now its screwed.
The hardware browser shows both pointing devices with the
device /dev/input/mice. That may be a key to the problem.
'cat /dev/input/mice' shows activity when I use the stylus,
but none when I use the mouse. And indeed, the stylus works
fine (well, almost) with the x server (x.org), but the mouse
does not. Is the kernel configured incorrectly ?
Comment 24 Alan Cox 2004-06-18 20:51:59 EDT
The 2.6.6 based errata has a pile of PS/2 fixes and is worth a first
try. For the cases where disabling the buggy bios emulation for usb
works we are kicking around a couple of possible ways to approach this
Comment 25 Nelson Guedes Paulo Junior 2004-08-10 14:41:15 EDT
I have a generic PS/2 mouse, it´s correctly detected, but it doesn't
work with any kernel, neiter 2.6.1 neiter 2.6.5 and it didn't work
during instalation, before instalation, now, or after upgrading X and
the Kernel. I've tried "noapic" as a kernel parameter, tried to change
some configuration manualy, but it won't work neiter in text mode.
If you need more information, ask me and please mail me asking:
npaulo AT linux DOT ime DOT usp DOT br
Thanks
Comment 26 Target 2004-08-23 01:09:02 EDT
I'll add in a "me too". My ps/2 logitech mouseman did not work during
the FC2 install, nor after. It was correctly identified and even
qualifies as a core pointer in that X will start, but it does not
respond whatsoever to input.

Updated to 2.6.8-1.521. Still no dice.

Disabling legacy USB in the bios corrects the problem on 2.6.1, 2.6.5
and 2.6.8, so that conflict still persists.
Comment 27 Alan Cox 2004-08-23 07:51:41 EDT
Please attach a dmidecode and an lspci -vxx if you ar eseeing it work
only without USB legacy.
Comment 28 Troy Davisson 2004-09-07 18:42:01 EDT
Created attachment 103568 [details]
lspci -vxx
Comment 29 Troy Davisson 2004-09-07 18:43:22 EDT
I'll go ahead and throw a comment in here.  I had this same problem
but with my PS/2 keyboard.  When booting into SMP, the keyboard would
immediately stop working and Kudzu would pick up something new (I
couldn't see what it was because my keyboard didn't work).

Once I disabled legacy USB support in the BIOS, it worked.  It worked
before this but only when not using a SMP kernel (dual Xeon machine).
 Attached are my dmidecode and lspic -vxx results right before
rebooting and trying the legacy USB fix.
Comment 30 Alan Cox 2004-09-07 18:50:29 EDT
Yeah the E7xxx stuff we know about. I've raised the matter with Intel
too so hopefully whoever originated the buggy bios code will
eventually find out.
Comment 31 Troy Davisson 2004-09-07 18:55:30 EDT
Created attachment 103569 [details]
dmidecode
Comment 32 Joe Wood 2004-11-27 06:59:47 EST
In section "ServerLayout" use
        InputDevice    "Mouse0" "CorePointer"

In section Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "PS/2"
        Option      "Device" "/dev/mouse0"
                                        ^
was     Option      "Device" "/dev/mouse"

I suspect this is a change in /dev

My logitech 3 button ps/2 mouse was recognised and all I have a
working X windows.
Comment 33 Dave Jones 2004-11-27 18:51:10 EST
any improvement with the 2.6.9 kernels ?
Comment 34 Joe Wood 2004-11-29 12:47:11 EST
Hmm, pay attention Joe!

Sorry, this happened to me under FC3 after the update from FC2, and 
the new kernel 2.6.9 was installed.
Comment 35 Mike A. Harris 2004-11-29 17:21:05 EST
Ok, is the original reporter still seeing this problem with the
latest kernel and other updates installed?  This is currently
filed against xorg-x11, but owned by the kernel maintainer,
which is a bit odd.

If the problem no longer occurs, it should be closed as fixed.
If it still occurs, people need to provide status about the
problem, and it should be assigned to the right component/person.

Please update status ASAP.
Comment 36 Jim Richardson 2004-12-01 08:54:37 EST
The problem I was having with my logitech wheel mouse has been
resoloved  as of 2.6.9. I NO LONGER need the psmouse.proto=imps kernel
parameter.

Note You need to log in before you can comment on or make changes to this bug.