Bug 12086 - Access denied to apache web sites after running the apche portion of linuxconf or netconf
Access denied to apache web sites after running the apche portion of linuxcon...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-11 10:55 EDT by Bruce D. Meyer
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce D. Meyer 2000-06-11 10:55:43 EDT
After using linuxconf / apache and trying to renter the web site the 
httpd.conf file has shrunk significantly, and I am forbidden, even as 
local host. Response is similar to:

x-------------------------x

Forbidden

You don't have permision to access / on this server.
and the apache error log shows this:
[Sun Jun  4 00:40:55 2000] [error] [client 168.70.103.32] client denied by
server configuration: /home/httpd/html

x-------------------------x

Following this advice from a deja newsgroup works:

Edit /etc/httpd/conf/access.conf. If that file is empty (or missing)
then edit /etc/httpd/conf/httpd.conf.

You'll see an area that says:
<Directory /home/httpd/html>

In that area, you should have:
allow from all


Apparently the conf program is inserting deny from all improperly.


Another user on that thread reported (But I have not confirmed): (I am 
quoting)

x---------------------------------x

Yep, Linuxconf shipped with Rh6.2 is buggy. It destroys httpd.conf on many 
systems (altough i do not know  what the "trigger factor" is for this bug)
 
Search httpd.conf for "Files" and you will find the 
 
<Files ... ... ... > header
 
which is SUPPOSED to look like this
 
<Files ~ "^\.ht">
 
if it looks any other way, edit it, restart apache (FULL stop/start, not 
restart) and never use linuxconf again. (or atleast not until redhat has 
declared this a bug)
 
Or use the "real" linuxconf and not Redhats bastardized version. 

x---------------------------------------x

I have had the above problem happen on three new Apache servers. (All 
different machines with RH62 installs)

Bruce Meyer
Comment 1 slive+bugzilla.redhat 2000-07-02 16:51:21 EDT
Is someone going to address this?  This problem is causing
no end of confused people in comp.infosystems.www.servers.unix.
Comment 2 John Clements 2000-07-12 02:00:47 EDT
I followed the above description but also found that linuxconf had inserted
quotes into all the <Directory...> tags. Once I fixed them everything worked.
jclements@selectsa.com
Comment 3 Nalin Dahyabhai 2000-08-07 08:22:18 EDT
Until it's verified that linuxconf will not trash httpd.conf, we're disabling
the module.
Comment 4 Brent Fox 2002-06-05 12:12:39 EDT
Closing because we don't ship linuxconf anymore
Comment 5 Red Hat Bugzilla 2006-02-21 13:47:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.