Bug 1208614 - disabling the dnf local plugin causes dnf to crash
disabling the dnf local plugin causes dnf to crash
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
: 1205837 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-02 12:55 EDT by Bruno Wolff III
Modified: 2015-04-27 04:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-plugins-extras-0.0.7-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-27 04:47:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2015-04-02 12:55:49 EDT
Description of problem:
changing enabled = true to enabled = false in the [main] section of /etc/dnf/plugins/local.conf causes dnf update to crash.

Version-Release number of selected component (if applicable):
python3-dnf-plugins-extras-local-0.0.6-1.fc23.noarch

Actual results:
dnf update
Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 115, in _main
    cli.configure(map(ucd, args))
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1010, in configure
    self.base.plugins.run_config()
  File "/usr/lib/python3.4/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python3.4/site-packages/dnf/util.py", line 157, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python3.4/site-packages/dnf-plugins/local.py", line 103, in config
    local_repo.baseurl = "file://{}".format(self.main["repodir"])
KeyError: 'repodir'
Comment 2 Honza Silhan 2015-04-03 09:32:44 EDT
*** Bug 1205837 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2015-04-21 08:24:24 EDT
dnf-plugins-extras-0.0.7-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.7-1.fc22
Comment 4 Fedora Update System 2015-04-22 18:48:07 EDT
Package dnf-plugins-extras-0.0.7-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.7-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6624/dnf-plugins-extras-0.0.7-1.fc22
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2015-04-27 04:47:15 EDT
dnf-plugins-extras-0.0.7-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.