Bug 120887 - Russian language support broken in KDE
Russian language support broken in KDE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-i18n (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 17:19 EDT by Boris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-03 05:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris 2004-04-14 17:19:58 EDT
Description of problem:

Two problems :

1. When KDE is selected as a user session, the language is not
switched automatically according to the selection in the gdm language
box. User has to go to KDE control and manually select language there.
This applies not only to russian, but to any language.

2. When Russian language is manually selected in KDE control center
the fonts are displayed correctly only when in gdm screen English was
selected as a session language. If Russian is selected in both gdm
language box and in KDE control menus all russian  letters are shown
as white boxes instead of actual fonts.

Same applies when you work in Russian-language gnome. When Russian is
 selected for the gnome session, gnome apps  are displayed correctly
with russian fonts, however all KDE programs don't show russian
letters at all only white boxes.

Those problems didn't appear in test1 release

Version-Release number of selected component (if applicable):
test2+

How reproducible:
always

Steps to Reproduce:

0. Create new user.

1. Choose russian as a language for the session in the gdm login
screen. and KDE as session choice. Log on.
No russian  menus and names appear.

2. Choose  russian as a language in KDE control panel
re-login.

3. Observe  empty white boxes instead of russian language fonts
and logout

4.   Choose Russian and Gnome in gdm logon screen. Log in.

5. Run any KDE application. Konqueror for example. Observe that no
russian letters are shown. White boxes instead of russian letters.


Actual results:
Bad Russian language support in KDE

Expected results:
Full Russian language support in KDE


Additional info:
Comment 1 Ngo Than 2004-06-03 05:18:56 EDT
it seems a bug in qt, which should be fixed in FC2. I cannot reproduce
this bug anymore. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.