Bug 120890 - file -k switch broken. Version update + patch
file -k switch broken. Version update + patch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 18:07 EDT by Eric Andresen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 03:45:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for newline translation in output (420 bytes, patch)
2004-04-14 18:08 EDT, Eric Andresen
no flags Details | Diff
Updated .spec file (5.76 KB, text/plain)
2004-04-14 18:08 EDT, Eric Andresen
no flags Details

  None (edit)
Description Eric Andresen 2004-04-14 18:07:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
The current version of the file package is 4.02-2, which has a bug
that makes the -k switch non functioning. The upstream package version
has a fix for this.

Using that updated package version, there is one minor bug due to a
literal \n being translated to \012 in the output.

I will attach the new .spec file, as well as the .patch for the
newline translation problem.

Version-Release number of selected component (if applicable):
file-4.09-1

How reproducible:
Always

Steps to Reproduce:
1. file -k somefile
2. ???
3. Profit.

Actual Results:  First match listed.

Expected Results:  All matches listed.

Additional info:
Comment 1 Eric Andresen 2004-04-14 18:08:19 EDT
Created attachment 99433 [details]
Patch for newline translation in output
Comment 2 Eric Andresen 2004-04-14 18:08:55 EDT
Created attachment 99434 [details]
Updated .spec file
Comment 4 Radek Vokal 2004-08-16 03:45:27 EDT
Patch added, updated to file-4.10

Note You need to log in before you can comment on or make changes to this bug.