Bug 1208902 - opendbx no longer builds on rawhide, F22, or F21 due to issues with doxygen
Summary: opendbx no longer builds on rawhide, F22, or F21 due to issues with doxygen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: opendbx
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Steve Jenkins
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-03 19:03 UTC by Steve Jenkins
Modified: 2015-04-21 19:05 UTC (History)
3 users (show)

Fixed In Version: opendbx-1.4.6-6.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-18 09:31:47 UTC


Attachments (Terms of Use)

Description Steve Jenkins 2015-04-03 19:03:25 UTC
Description of problem:
opendbx fails to build on rawhide, F22, and F21 because of doxygen related issues. Doxygen has changed its API in ways that are not backwards-compatible.

It does, however, build on F20, EL7, EL6, and EL5.

How reproducible:
100%


Steps to Reproduce:
1. Attempt to build opendbx on rawhide, F22, or F21 (even with the last spec file that did build in Aug 2014).


Actual results:
Build Fails


Expected results:
Build succeeds. :)


Additional info:

See the build logs in scratch builds:

DOES NOT BUILD:
Rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=9408182
F22: http://koji.fedoraproject.org/koji/taskinfo?taskID=9408187
F21: http://koji.fedoraproject.org/koji/taskinfo?taskID=9408197

DOES BUILD:
F20: http://koji.fedoraproject.org/koji/taskinfo?taskID=9408203
EL7: http://koji.fedoraproject.org/koji/taskinfo?taskID=9408209
EL6: http://koji.fedoraproject.org/koji/taskinfo?taskID=9408215
EL5: http://koji.fedoraproject.org/koji/taskinfo?taskID=9408221

Debian apparently had a similar issue:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=759951

However, I have been unable to replicate their approach to fixing using symlinks and patching. I'm probably just missing something simple, but I'm hoping for suggestions.

There must be a difference in the doxygen versions being used on the "DOES BUILD" systems vs the "DOES NOT BUILD" ones that's contributing to the issue, but I'm not sure of the proper approach to fix the failing ones.

Comment 1 Steve Jenkins 2015-04-03 20:34:03 UTC
Scott Kitterman (libopendbx packager for Debian) was generous enough to share his patch with me. CC-ing him to this bug in the hopes that he might provide some additional generous guidance. :)

Here's a build.log of my most recent failed attempt:

http://paste.fedoraproject.org/207063/14280922/

spec file and patches I'm using for this mockbuild are in my Develop branch here:

https://github.com/stevejenkins/OpenDBX-Fedora/tree/develop

See line 36 of that build.log for my attempt at a symlink to address the lib/opendbx/api vs. lib/opendbx/api.dox issue (based on the Debian fix).

But I must be doing it wrong because I get:

449. Warning: tag INPUT: input source `../lib/opendbx/api.dox' does not exist
450. warning: source ../lib/opendbx/api.dox is not a readable file or directory... skipping.

and the final death bell:

792. /usr/bin/install: cannot stat './man/man3/OpenDBX.3': No such file or directory

I've been pulling my f*&ing hair out on this all day. Anything obvious I'm just missing?

Comment 2 Steve Jenkins 2015-04-03 20:57:13 UTC
Turns out I WAS going the ln -s wrong.

Building clean now on Rawhide. Testing other platforms... stay tuned.

Comment 4 Fedora Update System 2015-04-03 22:09:33 UTC
opendbx-1.4.6-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/opendbx-1.4.6-6.fc22

Comment 5 Fedora Update System 2015-04-03 22:09:39 UTC
opendbx-1.4.6-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/opendbx-1.4.6-6.fc21

Comment 6 Fedora Update System 2015-04-03 22:09:47 UTC
opendbx-1.4.6-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/opendbx-1.4.6-6.el6

Comment 7 Fedora Update System 2015-04-03 22:09:54 UTC
opendbx-1.4.6-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/opendbx-1.4.6-6.fc20

Comment 8 Fedora Update System 2015-04-04 16:30:58 UTC
Package opendbx-1.4.6-6.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing opendbx-1.4.6-6.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5507/opendbx-1.4.6-6.fc22
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-04-04 18:39:35 UTC
opendbx-1.4.6-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/opendbx-1.4.6-6.el5

Comment 10 Fedora Update System 2015-04-04 18:39:40 UTC
opendbx-1.4.6-6.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/opendbx-1.4.6-6.el7

Comment 11 Fedora Update System 2015-04-18 09:31:47 UTC
opendbx-1.4.6-6.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-04-18 09:47:23 UTC
opendbx-1.4.6-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-04-20 18:36:06 UTC
opendbx-1.4.6-6.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2015-04-20 18:36:21 UTC
opendbx-1.4.6-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-04-20 18:37:02 UTC
opendbx-1.4.6-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2015-04-21 19:05:15 UTC
opendbx-1.4.6-6.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.