Bug 1208909 - tracer: NameError: global name 'installed' is not defined
Summary: tracer: NameError: global name 'installed' is not defined
Status: CLOSED DUPLICATE of bug 1187763
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-03 20:48 UTC by orti1980
Modified: 2015-04-07 12:42 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-04-07 10:19:44 UTC


Attachments (Terms of Use)

Description orti1980 2015-04-03 20:48:31 UTC
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 141, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 160, in resolving
    base.do_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 221, in do_transaction
    self.plugins.run_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python2.7/site-packages/dnf/util.py", line 157, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python2.7/site-packages/dnf-plugins/tracer.py", line 59, in transaction
    args = ["tracer", "-n"] + list(installed | erased)
NameError: global name 'installed' is not defined

Comment 1 Radek Holy 2015-04-07 10:19:44 UTC
The summary is bit confusing. It's related to snapper while the traceback is caused by tracer. I assume that you're reporting the tracer problem. Then, it is a duplicate of bug 1187763.

*** This bug has been marked as a duplicate of bug 1187763 ***


Note You need to log in before you can comment on or make changes to this bug.