Bug 1208918 - RFE: dnf shouldn't stop processing the command line at the first unknown package
RFE: dnf shouldn't stop processing the command line at the first unknown package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: FutureFeature, Reopened
: 1232990 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-03 19:03 EDT by Bruno Wolff III
Modified: 2015-08-19 03:51 EDT (History)
9 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.10-1.fc23
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 22:14:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2015-04-03 19:03:50 EDT
Description of problem:

With you I nused to use the following construct:
yum install -y `cat putpack`
where putback contained a list of packages I had removed because the installed version was not currently in any repo. They typically were packages that were dropped or had soname conflicts. yum would report on packages that no longer existed and still try to install the rest. dnf stops processing at the first unknown package which is annoying if there are a number of dropped packages, since I only find out about one for each run. I don't so much mind that when there is a problem that dnf doesn't do anything, but it would be nice if it reported all of the unknown packages when it runs.
Comment 1 Honza Silhan 2015-04-07 15:33:45 EDT

*** This bug has been marked as a duplicate of bug 1197456 ***
Comment 2 Radek Holy 2015-04-08 01:55:19 EDT
With all the respect, I don't think this is a duplicate of that bug. The request is to print all of the packages that were not found and stop the process after that. It makes a lot of sense to me.
Comment 3 Radek Holy 2015-06-18 04:26:52 EDT
*** Bug 1232990 has been marked as a duplicate of this bug. ***
Comment 4 Andrew McNabb 2015-06-18 10:28:17 EDT
Yes, I agree that this is not a duplicate of bug 1197456.

If a command contains 10 missing packages, then one must repeatedly remove the missing package that dnf reports and rerun. The process would be far less tedious if dnf reported upfront all missing packages that had been requested.
Comment 5 Tom Horsley 2015-07-18 18:01:52 EDT
Amen! I'm trying to update my f22 partition to have as many of the same packages installed as were on my f20 partition, and only telling me about 1 at a time is incredibly worthless.
Comment 6 Honza Silhan 2015-07-21 08:01:15 EDT
PR: https://github.com/rpm-software-management/dnf/pull/306
Comment 7 Fedora Update System 2015-08-10 06:05:26 EDT
dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23
Comment 8 Fedora Update System 2015-08-10 06:49:29 EDT
dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
Comment 9 Fedora Update System 2015-08-10 22:10:42 EDT
Package dnf-plugins-core-0.1.10-1.fc22, dnf-1.1.0-1.fc22, hawkey-0.6.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.10-1.fc22 dnf-1.1.0-1.fc22 hawkey-0.6.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13162/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2015-08-14 22:14:02 EDT
dnf-plugins-core-0.1.10-1.fc22, hawkey-0.6.0-1.fc22, dnf-1.1.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-08-19 03:51:15 EDT
dnf-plugins-core-0.1.10-1.fc23, hawkey-0.6.0-1.fc23, dnf-1.1.0-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.