Bug 1208946 - libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
Summary: libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libkpeople
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: ktp-kf5
Blocks: plasma5
TreeView+ depends on / blocked
 
Reported: 2015-04-04 10:15 UTC by Sudhir Khanger
Modified: 2015-04-21 19:07 UTC (History)
2 users (show)

Fixed In Version: libkpeople-0.3.0-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 18:42:58 UTC


Attachments (Terms of Use)

Description Sudhir Khanger 2015-04-04 10:15:55 UTC
Description of problem:

Transaction check error:
  file /usr/share/locale/bs/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/cs/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/da/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/de/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/el/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/fi/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/fr/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/hu/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/ja/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/lt/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/nl/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/pl/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/pt/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/pt_BR/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/ro/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/ru/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/sk/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/sl/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/sv/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  file /usr/share/locale/uk/LC_MESSAGES/libkpeople.mo from install of kf5-kpeople-5.8.0-1.fc21.x86_64 conflicts with file from package libkpeople-0.3.0-1.fc21.x86_64
  
  


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Rex Dieter 2015-04-04 15:55:48 UTC
Looks like libkpeople is only ever used by ktp-common-internals, so one easy fix here would be for kf5-kpeople to Obsoletes: libkpeople

(and the new kf5 ktp stack will take care of updating ktp-common-internals)

Comment 2 Rex Dieter 2015-04-04 15:59:14 UTC
For reporter here, it's safe for you to either not install kf5-kpeople or to uninstall libkpeople (and old ktp stack which is unusable on plasma5 anyway) for now.

Comment 3 Fedora Update System 2015-04-07 22:34:41 UTC
libkpeople-0.3.0-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libkpeople-0.3.0-3.fc22

Comment 4 Fedora Update System 2015-04-07 22:35:21 UTC
libkpeople-0.3.0-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libkpeople-0.3.0-3.fc21

Comment 5 Fedora Update System 2015-04-07 22:35:56 UTC
libkpeople-0.3.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libkpeople-0.3.0-3.fc20

Comment 6 Fedora Update System 2015-04-08 18:37:05 UTC
Package libkpeople-0.3.0-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libkpeople-0.3.0-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5784/libkpeople-0.3.0-3.fc22
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-04-21 18:42:58 UTC
libkpeople-0.3.0-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2015-04-21 19:07:33 UTC
libkpeople-0.3.0-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.