Bug 120896 - Ethereal not being compiled with GTK 2
Ethereal not being compiled with GTK 2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ethereal (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 20:54 EDT by Jerone Young
Modified: 2015-03-04 20:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 06:49:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerone Young 2004-04-14 20:54:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040312

Description of problem:
Ethreal is being built with gtk 1...when everything
else in FC2 is being built with gtk2. The option in
configure to do this is "--enable-gtk2". For the sake
of all that is "Pretty"... please start compiling this
package with gtk2!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Launch Ethreal
2. See how ugly gtk 1 is 
3. Scream out loud saying "WHY OH WHY ARE THEY STILL COMPILING WITH
GTK 1, WHEN IT SUPPORTS GTK2...AND EVERYTHING IN THE DISTRO IS
COMPILIED WITH GTK 2"
    

Actual Results:  You get nice pretty interface to look at network packets.

Additional info:
Comment 1 Phil Knirsch 2004-04-15 10:38:36 EDT
:-)) What a funny bugreport. :-)

And before you get a heartattack i'll put a "--enable-gtk2" in the
configure script for FC2.

Read ya, Phil
Comment 2 John Thacker 2004-04-27 13:27:41 EDT
Since we've switched to compiling with gtk2, the Requires: gtk+ >= 1.2
line needs to be removed from the ethereal-gnome portion of the
specfile.  ethereal-gnome now depends on gtk2, not gtk1, so that line
doesn't need to be in there.
Comment 3 Jerone Young 2004-06-05 00:41:12 EDT
Requires:       gtk+ >= 1.2

is still apart of this spec file , it needs to be gtk2
Needs to be changed to 
Requires: gtk2 >= 2.4.0

Comment 4 Jerone Young 2004-06-05 00:41:41 EDT
Also 
BuildRequires:  gtk+-devel >= 1.2

Needs to be removed
Comment 5 Phil Knirsch 2004-07-14 06:49:58 EDT
Fixed in ethereal-0.10.5-1 and later in the development tree.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.