Bug 120901 - half-closed connection to server prevents reconnection
half-closed connection to server prevents reconnection
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 21:49 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 13:56:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-04-14 21:49:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
If your home NAT box or so changes its external IP address, such that
connections to IRC servers are broken, xchat will *sometimes* become
unable to reconnect to some servers.  The symptom is that, even if you
reconnect (automatically or by hand), or even if you explicitly
disconnect and connect again, it will connect to the server and remain
in a state in which it doesn't send or receive anything.  Sometimes
the server will quickly break the connection, and xchat will attempt
to reconnect over and over without ever succeeding.  Other times, it
just stays in this zombie state in which you can read what's going on,
but no commands you send are honored.  I can see that there's a single
TCP connection between xchat and the IRC server using lsof, and I can
see with tcpdump that the connection is fully established and there's
some short exchange, but then xchat doesn't send anything else. 
strace confirmed it didn't write anything else to the connection.

Version-Release number of selected component (if applicable):
xchat-2.0.7-5

How reproducible:
Sometimes

Steps to Reproduce:
1.Connect to some IRC servers
2.Reset your DSL connection such that your home gateway/NAT box gets a
new IP address (re-connecting to a VPN server that assigns IP
addresses dynamically works just as well)

Actual Results:  Sometimes it gets into the weird state described above

Expected Results:  Sometimes it reconnects properly as it should

Additional info:

The only way I know to fix the problem is to restart xchat.

Note You need to log in before you can comment on or make changes to this bug.