Bug 1209014 - vdsm might report interfaces without IP address when using a slow DHCP server
Summary: vdsm might report interfaces without IP address when using a slow DHCP server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Dan Kenigsberg
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks: 1218637
TreeView+ depends on / blocked
 
Reported: 2015-04-05 08:19 UTC by Ido Barkan
Modified: 2016-03-09 19:35 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1218637 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:35:02 UTC
oVirt Team: Network
Target Upstream Version:
ylavi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC
oVirt gerrit 39381 None None None Never
oVirt gerrit 39529 ovirt-3.5 MERGED net: Force blocking DHCP when restoring networks Never

Description Ido Barkan 2015-04-05 08:19:18 UTC
Description of problem:
When VDSM is restoring networks which are configured to use DHCP, and the process of obtaining a valid IP and lease is too slow. VDSM service might start and report networks without IP addresses to engine. When DHCP addresses will finally be assigned, then no mechanism is in place to update the engine about that.
This is hap penning since the default behavior of VDSM is to not wait for the IP address after 'ifup' a device.

Version-Release number of selected component (if applicable):
vdsm-python-4.16.13-2

How reproducible:
This can be reproduced by using a slow DHCP server. So in most cases this will not be reproduced. This is also more likely to happen when there are many such networks. Since VDSM default behavior for DHCP interfaces not waiting for IP address, it will finish network restoration a lot faster than the IP assignment process.


Steps to Reproduce:
1. create a network with bootproto=dhcp (do _not_ use blockingdhcp=True).
2. call setSafeNetworkConfig to persist the network.
3. reboot the host

Actual results:
The first call to getCapabilities to VDSM will report that at least some of the devices are still missing IP addresses.

Expected results:
When VDSM service starts, it should have all managed networks in a functioning state.


Additional info:

Comment 4 Ido Barkan 2015-05-31 11:52:17 UTC
This bug can also be reproduced by persisting many (10?) networks with dhcp. This will probably result in at least part of the networks reported without IP.

Comment 5 Michael Burman 2015-06-01 06:16:35 UTC
Verified on - 3.6.0-0.0.master.20150519172219.git9a2e2b3.el6
with vdsm-4.17.0-822.git9b11a18.el7.noarch and dhclient-4.2.5-36.el7.x86_64

Comment 9 errata-xmlrpc 2016-03-09 19:35:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.